summaryrefslogtreecommitdiffstats
path: root/net/rfkill/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/rfkill/Makefile')
-rw-r--r--net/rfkill/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net/rfkill/Makefile b/net/rfkill/Makefile
new file mode 100644
index 000000000..dc47b6174
--- /dev/null
+++ b/net/rfkill/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the RF switch subsystem.
+#
+
+rfkill-y += core.o
+rfkill-$(CONFIG_RFKILL_INPUT) += input.o
+obj-$(CONFIG_RFKILL) += rfkill.o
+obj-$(CONFIG_RFKILL_GPIO) += rfkill-gpio.o