summaryrefslogtreecommitdiffstats
path: root/net/smc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/smc/Makefile')
-rw-r--r--net/smc/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/net/smc/Makefile b/net/smc/Makefile
new file mode 100644
index 000000000..875efcd12
--- /dev/null
+++ b/net/smc/Makefile
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: GPL-2.0-only
+ccflags-y += -I$(src)
+obj-$(CONFIG_SMC) += smc.o
+obj-$(CONFIG_SMC_DIAG) += smc_diag.o
+smc-y := af_smc.o smc_pnet.o smc_ib.o smc_clc.o smc_core.o smc_wr.o smc_llc.o
+smc-y += smc_cdc.o smc_tx.o smc_rx.o smc_close.o smc_ism.o smc_netlink.o smc_stats.o
+smc-y += smc_tracepoint.o
+smc-$(CONFIG_SYSCTL) += smc_sysctl.o