summaryrefslogtreecommitdiffstats
path: root/net/tls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/tls/Makefile')
-rw-r--r--net/tls/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/net/tls/Makefile b/net/tls/Makefile
new file mode 100644
index 000000000..e41c80048
--- /dev/null
+++ b/net/tls/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the TLS subsystem.
+#
+
+CFLAGS_trace.o := -I$(src)
+
+obj-$(CONFIG_TLS) += tls.o
+
+tls-y := tls_main.o tls_sw.o tls_proc.o trace.o tls_strp.o
+
+tls-$(CONFIG_TLS_TOE) += tls_toe.o
+tls-$(CONFIG_TLS_DEVICE) += tls_device.o tls_device_fallback.o