summaryrefslogtreecommitdiffstats
path: root/net/x25/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/x25/Makefile')
-rw-r--r--net/x25/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/net/x25/Makefile b/net/x25/Makefile
new file mode 100644
index 000000000..5dd544a23
--- /dev/null
+++ b/net/x25/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux X.25 Packet layer.
+#
+
+obj-$(CONFIG_X25) += x25.o
+
+x25-y := af_x25.o x25_dev.o x25_facilities.o x25_in.o \
+ x25_link.o x25_out.o x25_route.o x25_subr.o \
+ x25_timer.o x25_proc.o x25_forward.o
+x25-$(CONFIG_SYSCTL) += sysctl_net_x25.o