summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.kcov
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.kcov')
-rw-r--r--scripts/Makefile.kcov6
1 files changed, 6 insertions, 0 deletions
diff --git a/scripts/Makefile.kcov b/scripts/Makefile.kcov
new file mode 100644
index 000000000..67e8cfe34
--- /dev/null
+++ b/scripts/Makefile.kcov
@@ -0,0 +1,6 @@
+# SPDX-License-Identifier: GPL-2.0-only
+kcov-flags-$(CONFIG_CC_HAS_SANCOV_TRACE_PC) += -fsanitize-coverage=trace-pc
+kcov-flags-$(CONFIG_KCOV_ENABLE_COMPARISONS) += -fsanitize-coverage=trace-cmp
+kcov-flags-$(CONFIG_GCC_PLUGIN_SANCOV) += -fplugin=$(objtree)/scripts/gcc-plugins/sancov_plugin.so
+
+export CFLAGS_KCOV := $(kcov-flags-y)