summaryrefslogtreecommitdiffstats
path: root/bootstrap.conf
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:19:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:19:27 +0000
commite0023883c6d2e6745a19e4b48e186ed156c1fca8 (patch)
tree1a48b8056ec984385d0d862b683535d04d6ed215 /bootstrap.conf
parentInitial commit. (diff)
downloadman-db-e0023883c6d2e6745a19e4b48e186ed156c1fca8.tar.xz
man-db-e0023883c6d2e6745a19e4b48e186ed156c1fca8.zip
Adding upstream version 2.11.2.upstream/2.11.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'bootstrap.conf')
-rw-r--r--bootstrap.conf157
1 files changed, 157 insertions, 0 deletions
diff --git a/bootstrap.conf b/bootstrap.conf
new file mode 100644
index 0000000..63883fe
--- /dev/null
+++ b/bootstrap.conf
@@ -0,0 +1,157 @@
+# Bootstrap configuration.
+
+# Copyright (C) 2006-2018 Free Software Foundation, Inc.
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+
+GNULIB_REVISION=df336dc1ae60d8ad9f452f2234951133fe617bb0
+
+# gnulib modules used by this package.
+gnulib_modules="
+ argp
+ array-list
+ attribute
+ c99
+ canonicalize
+ closedir
+ dirent
+ dirname
+ error
+ fcntl-h
+ flock
+ fnmatch-gnu
+ fstat
+ getline
+ gettext-h
+ gitlog-to-changelog
+ glob
+ gnupload
+ hash-map
+ hash-pjw-bare
+ hash-set
+ havelib
+ idpriv-drop
+ idpriv-droptemp
+ lchown
+ lib-ignore
+ linkedhash-list
+ localcharset
+ manywarnings
+ memmem
+ minmax
+ mkdtemp
+ mkstemp
+ nanosleep
+ nonblocking
+ openat
+ opendir
+ progname
+ raise
+ rbtree-list
+ regex
+ rename
+ renameat
+ setenv
+ sigaction
+ signal-h
+ sigpipe
+ sigprocmask
+ stat-time
+ stdbool
+ stpcpy
+ strcase
+ strcasestr
+ strerror
+ strsep
+ tempname
+ termios
+ timespec
+ unlinkat
+ utimens
+ verror
+ warnings
+ xalloc
+ xgetcwd
+ xlist
+ xmap
+ xset
+ xstdopen
+ xstrndup
+ xvasprintf
+"
+
+gnulib_tool_option_extras="\
+ --po-base=gl/ref-po \
+ --no-conditional-dependencies \
+ --libtool \
+ --macro-prefix=gl \
+ --po-domain=man-db \
+ --no-vc-files \
+"
+
+# This doesn't currently exist, but we set it to avoid confusion with 'gl'
+# as the local output directory.
+local_gl_dir=gnulib-local
+
+gnulib_name=libgnu
+source_base=gl/lib
+m4_base=gl/m4
+
+COPYRIGHT_HOLDER='Colin Watson <cjwatson@debian.org>'
+MSGID_BUGS_ADDRESS="$COPYRIGHT_HOLDER"
+
+# Additional xgettext options to use. Use "\\\newline" to break lines.
+XGETTEXT_OPTIONS=$XGETTEXT_OPTIONS'\\\
+ --from-code=UTF-8\\\
+ --flag=debug:1:c-format\\\
+ --flag=debug_error:1:c-format\\\
+ --flag=fatal:2:c-format\\\
+'
+
+checkout_only_file=
+copy=true
+vc_ignore=
+
+SKIP_PO=t
+
+# Build prerequisites
+buildreq="\
+autoconf 2.64
+automake 1.14
+autopoint 0.18.3
+gettext 0.18.3
+git 1.5.5
+tar -
+"
+
+bootstrap_post_import_hook () {
+ patch -s -p1 <patches/argp-domain.patch
+
+ # gnulib-tool installs its own versions of gettext infrastructure files
+ # such as po/Makefile.in.in, which don't necessarily match our configured
+ # AM_GNU_GETTEXT_VERSION. To cope with this, we tell gnulib-tool to
+ # install into a temporary directory (using --po-base above) and fix
+ # things up here.
+ cp -a gl/ref-po/LINGUAS gl/ref-po/POTFILES.in gl/po/
+ sed 's,^subdir *=.*,subdir = gl/po,' gl/ref-po/Makevars >gl/po/Makevars
+ if ls gl/ref-po/*.po >/dev/null 2>&1; then
+ cp -a gl/ref-po/*.po gl/po/
+ fi
+ rm -rf gl/ref-po
+}
+
+bootstrap_epilogue () {
+ mv INSTALL docs/INSTALL.autoconf
+}