summaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:39:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:39:48 +0000
commit3ade071f273aaa973e44bf95d6b1d4913a18f03b (patch)
treee2f99d267ae18427645404f215b984afbe73098d /docs
parentInitial commit. (diff)
downloadnautilus-3ade071f273aaa973e44bf95d6b1d4913a18f03b.tar.xz
nautilus-3ade071f273aaa973e44bf95d6b1d4913a18f03b.zip
Adding upstream version 43.2.upstream/43.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'docs')
-rw-r--r--docs/meson.build4
-rw-r--r--docs/nautilus-autorun-software.126
-rw-r--r--docs/nautilus.172
-rw-r--r--docs/reference/meson.build31
-rw-r--r--docs/reference/nautilus.toml.in22
-rw-r--r--docs/reference/urlmap.js9
6 files changed, 164 insertions, 0 deletions
diff --git a/docs/meson.build b/docs/meson.build
new file mode 100644
index 0000000..a54574f
--- /dev/null
+++ b/docs/meson.build
@@ -0,0 +1,4 @@
+install_man('nautilus.1')
+install_man('nautilus-autorun-software.1')
+
+subdir('reference')
diff --git a/docs/nautilus-autorun-software.1 b/docs/nautilus-autorun-software.1
new file mode 100644
index 0000000..9ecbd4a
--- /dev/null
+++ b/docs/nautilus-autorun-software.1
@@ -0,0 +1,26 @@
+.TH nautilus-autorun-software 1 "3 July 2019"
+
+.SH NAME
+Run Software \- helper tool
+
+.SH SYNOPSIS
+.B nautilus-autorun-software
+.RI "" "mount-uri"
+.br
+
+.SH DESCRIPTION
+.B nautilus-autorun-software
+is a helper tool for the GNOME desktop to start software from media with
+Autostart files.
+.br
+
+It is the default "x-content/unix-software" handler for the GNOME desktop.
+.br
+
+.SH SEE ALSO
+Autostart files are described at
+https://specifications.freedesktop.org/autostart-spec/autostart-spec-latest.html
+
+.SH BUGS
+Bug reports can be found and filed at
+https://gitlab.gnome.org/GNOME/nautilus/issues
diff --git a/docs/nautilus.1 b/docs/nautilus.1
new file mode 100644
index 0000000..c6f0f72
--- /dev/null
+++ b/docs/nautilus.1
@@ -0,0 +1,72 @@
+.\" Hey, EMACS: -*- nroff -*-
+.\" First parameter, NAME, should be all caps
+.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+.\" other parameters are allowed: see man(7), man(1)
+.TH Nautilus 1 "4 July 2019"
+.\" Please adjust this date whenever revising the manpage.
+.\"
+.\" Some roff macros, for reference:
+.\" .nh disable hyphenation
+.\" .hy enable hyphenation
+.\" .ad l left justify
+.\" .ad b justify to both left and right margins
+.\" .nf disable filling
+.\" .fi enable filling
+.\" .br insert line break
+.\" .sp <n> insert n+1 empty lines
+.\" for manpage-specific macros, see man(7)
+.SH NAME
+nautilus \- a file manager for GNOME
+
+.SH SYNOPSIS
+.B nautilus
+.RI [ options ] " URIs" ...
+.br
+
+.SH DESCRIPTION
+.B nautilus
+is a file manager, designed for the GNOME 3 desktop.
+.br
+
+.SH OPTIONS
+.TP
+.BR \-c ", " \-\-check
+Perform a quick set of self-check tests.
+
+.TP
+.B \-\-version
+Show the version of the program.
+
+.TP
+.BR \-w ", " \-\-new-window
+Always open a new window for browsing specified URIs.
+
+.TP
+.BR \-q ", " \-\-quit
+Quit Nautilus.
+
+.TP
+.BR \-s ", " \-\-select
+Select specified URI in parent folder.
+
+.TP
+.BR \-h ", " \-\-help
+Show a summary of options.
+
+.TP
+Other standard GNOME options not listed here are also supported.
+
+.SH SEE ALSO
+The documentation may be accessed by pressing \fIF1\fR in the application or
+via the application menu.
+
+For further information, visit the website
+https://wiki.gnome.org/Apps/Nautilus
+
+.SH BUGS
+Bug reports can be found and filed at
+https://gitlab.gnome.org/GNOME/nautilus/issues
+
+.\"This manual page was written by Takuo KITAME <kitame@debian.org> and Dafydd
+.\"Harries <daf@muse.19inch.net> for the Debian GNU/Linux system (but may be used
+.\"by others).
diff --git a/docs/reference/meson.build b/docs/reference/meson.build
new file mode 100644
index 0000000..b617ba9
--- /dev/null
+++ b/docs/reference/meson.build
@@ -0,0 +1,31 @@
+toml_data = configuration_data()
+toml_data.set('VERSION', meson.project_version())
+
+nautilus_toml = configure_file(
+ input: 'nautilus.toml.in',
+ output: 'nautilus.toml',
+ configuration: toml_data,
+)
+
+custom_target(
+ 'nautilus-doc',
+ input: [
+ nautilus_toml,
+ nautilus_extension_gir[0],
+ ],
+ output: 'nautilus',
+ command: [
+ gi_docgen,
+ 'generate',
+ '--quiet',
+ '--add-include-path=@0@'.format(meson.project_source_root() / 'libnautilus-extension'),
+ '--config=@INPUT0@',
+ '--output-dir=@OUTPUT@',
+ '--no-namespace-dir',
+ '--content-dir=@0@'.format(meson.current_source_dir()),
+ '@INPUT1@',
+ ],
+ build_by_default: true,
+ install: true,
+ install_dir: docdir,
+)
diff --git a/docs/reference/nautilus.toml.in b/docs/reference/nautilus.toml.in
new file mode 100644
index 0000000..1d160ad
--- /dev/null
+++ b/docs/reference/nautilus.toml.in
@@ -0,0 +1,22 @@
+[library]
+version = "@VERSION@"
+description = "Nautilus Extension API"
+license = "GPL-2.0-or-later"
+browse_url = "https://gitlab.gnome.org/GNOME/nautilus/"
+repository_url = "https://gitlab.gnome.org/GNOME/nautilus.git"
+devhelp = true
+search_index = true
+
+[theme]
+name = "basic"
+show_index_summary = true
+show_class_hierarchy = true
+
+[source-location]
+# The base URL for the web UI
+base_url = "https://gitlab.gnome.org/GNOME/nautilus/-/blob/master/"
+# The format for links, using "filename" and "line" for the format
+file_format = "{filename}#L{line}"
+
+[extra]
+urlmap_file = "urlmap.js"
diff --git a/docs/reference/urlmap.js b/docs/reference/urlmap.js
new file mode 100644
index 0000000..84b05c3
--- /dev/null
+++ b/docs/reference/urlmap.js
@@ -0,0 +1,9 @@
+// SPDX-FileCopyrightText: 2021 GNOME Foundation
+// SPDX-License-Identifier: LGPL-2.1-or-later
+
+// A map between namespaces and base URLs for their online documentation
+baseURLs = [
+ ["GLib", "https://docs.gtk.org/glib/"],
+ ["Gio", "https://docs.gtk.org/gio/"],
+ ["GObject", "https://docs.gtk.org/gobject/"],
+];