summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:39:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:39:48 +0000
commit3ade071f273aaa973e44bf95d6b1d4913a18f03b (patch)
treee2f99d267ae18427645404f215b984afbe73098d /test/meson.build
parentInitial commit. (diff)
downloadnautilus-3ade071f273aaa973e44bf95d6b1d4913a18f03b.tar.xz
nautilus-3ade071f273aaa973e44bf95d6b1d4913a18f03b.zip
Adding upstream version 43.2.upstream/43.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
new file mode 100644
index 0000000..f8bcdac
--- /dev/null
+++ b/test/meson.build
@@ -0,0 +1,21 @@
+# When adding new tests, it is useful to set some environment variables.
+# You can do it like so:
+#
+# test(
+# name,
+# executable,
+# env: [
+# test_env,
+# 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+# 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
+# ]
+# )
+#
+# G_TEST_BUILDDIR and G_TEST_SRCDIR cannot be preset, since
+# the test sources are scattered.
+test_env = [
+ 'GSETTINGS_SCHEMA_DIR=@0@'.format(join_paths(meson.project_build_root(), 'data')),
+ 'RUNNING_TESTS=@0@'.format('TRUE')
+]
+
+subdir('automated')