summaryrefslogtreecommitdiffstats
path: root/apache/share/man
diff options
context:
space:
mode:
Diffstat (limited to 'apache/share/man')
-rw-r--r--apache/share/man/Makefile59
-rw-r--r--apache/share/man/man.in19
-rw-r--r--apache/share/man/service-tools.7.rst124
3 files changed, 202 insertions, 0 deletions
diff --git a/apache/share/man/Makefile b/apache/share/man/Makefile
new file mode 100644
index 0000000..ab33e62
--- /dev/null
+++ b/apache/share/man/Makefile
@@ -0,0 +1,59 @@
+# Open Infrastructure: service-tools
+
+# Copyright (C) 2014-2022 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Depends: python3-docutils
+
+RST2MAN = rst2man \
+ --no-datestamp \
+ --no-generator \
+ --strict \
+ --strip-comments \
+ --tab-width=4 \
+ --verbose
+
+VERSION := $(shell cat ../../../VERSION.txt)
+
+SHELL := sh -e
+
+all: build
+
+build: man
+
+rebuild: clean build
+
+man: man.in *.rst
+ @echo -n "Creating manpages... "
+
+ @for FILE in *.rst; \
+ do \
+ cp man.in $$(basename $${FILE} .rst); \
+ $(RST2MAN) $${FILE} | \
+ sed -e '/^.\\" Man page generated/d' \
+ -e '/^.\\" Generated by/d' \
+ -e "s|^\(.TH .*\) \(\"\" \"\"\) |\1 $${VERSION} service-tools |" \
+ >> $$(basename $${FILE} .rst); \
+ echo -n "."; \
+ done
+
+ @echo " done."
+
+clean:
+ rm -f *.[0-9]
+
+.PHONY: all clean build rebuild man
diff --git a/apache/share/man/man.in b/apache/share/man/man.in
new file mode 100644
index 0000000..f95ca67
--- /dev/null
+++ b/apache/share/man/man.in
@@ -0,0 +1,19 @@
+.\" Open Infrastructure: service-tools
+.\"
+.\" Copyright (C) 2014-2022 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+.\"
+.\" SPDX-License-Identifier: GPL-3.0+
+.\"
+.\" This program is free software: you can redistribute it and/or modify
+.\" it under the terms of the GNU General Public License as published by
+.\" the Free Software Foundation, either version 3 of the License, or
+.\" (at your option) any later version.
+.\"
+.\" This program is distributed in the hope that it will be useful,
+.\" but WITHOUT ANY WARRANTY; without even the implied warranty of
+.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.\" GNU General Public License for more details.
+.\"
+.\" You should have received a copy of the GNU General Public License
+.\" along with this program. If not, see <https://www.gnu.org/licenses/>.
+.\"
diff --git a/apache/share/man/service-tools.7.rst b/apache/share/man/service-tools.7.rst
new file mode 100644
index 0000000..d1cbf6b
--- /dev/null
+++ b/apache/share/man/service-tools.7.rst
@@ -0,0 +1,124 @@
+.. Open Infrastructure: apache-tools
+
+.. Copyright (C) 2014-2022 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+..
+.. SPDX-License-Identifier: GPL-3.0+
+..
+.. This program is free software: you can redistribute it and/or modify
+.. it under the terms of the GNU General Public License as published by
+.. the Free Software Foundation, either version 3 of the License, or
+.. (at your option) any later version.
+..
+.. This program is distributed in the hope that it will be useful,
+.. but WITHOUT ANY WARRANTY; without even the implied warranty of
+.. MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.. GNU General Public License for more details.
+..
+.. You should have received a copy of the GNU General Public License
+.. along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+============
+apache-tools
+============
+
+----------------------------------
+Extra tools for Apache HTTP server
+----------------------------------
+
+:manual section: 7
+:manual group: Open Infrastructure
+
+Description
+===========
+
+This package is a collection of extra tools for the Apache HTTP server,
+currently containing:
+
+ * alternative icons for Apache autoindex
+ (Tango Icons and Font Awesome based themes)
+
+Download
+========
+
+| Upstream Releases:
+| https://get.open-infrastructure.net/software/service-tools/upstream
+
+| Upstream Sources:
+| https://git.open-infrastructure.net/software/service-tools
+
+| Debian Releases:
+| https://get.open-infrastructure.net/software/service-tools/debian
+
+| Debian Sources:
+| https://git.progress-linux.org/users/daniel/debian/packages/open-infrastructure-service-tools
+
+Installation
+============
+
+Source
+------
+
+| $ sudo apt install git make python3-docutils
+| $ git clone https://git.open-infrastructure.net/software/service-tools
+| $ cd service-tools/apache && sudo make install
+
+Debian 9 (stretch) and newer
+----------------------------
+
+| $ sudo apt install apache-tools
+
+Development
+===========
+
+Bug reports, feature requests, help, patches, support and everything else are
+welcome on the Open Infrastructure Software Mailing List
+(https://lists.open-infrastructure.net/listinfo/software).
+
+Please base patches against the 'next' Git branch using common sense
+(https://www.kernel.org/doc/Documentation/SubmittingPatches).
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System
+(https://bugs.debian.org).
+
+Known limitations
+=================
+
+Changing from one icon set to the other requires a reload of the apache webserver.
+
+Usage
+=====
+
+The default icon theme is determined by the /usr/share/apache-icons/default
+(and /usr/share/apache-icons/default.conf respectivly) file.
+
+On Debian based system "sudo update-alternatives --config apache-icons" can be
+used to automatically select the active icon theme (including the default apache
+icons).
+
+The following themes are available:
+
+ * awesome-png: Fork Awesome based, PNG format
+ * awesome-svg: Fork Awesome based, SVG format
+ * tango-png: Tango Icons based, PNG format
+ * tango-svg: Tango Icons based, SVG format
+
+The SVG themes are preferable because they are sharper and scale losless.
+Very old browser can not render SVG icons, use PNG if that is a concern.
+
+An example of the tango-svg theme can be seen on
+https://get.open-infrastructure.net.
+
+Links
+=====
+
+| * Fork Awesome
+| (https://forkaweso.me)
+
+| * Tango Desktop Project
+| (http://tango.freedesktop.org)
+
+Authors
+=======
+
+service-tools were written by Daniel Baumann
+<daniel.baumann@open-infrastructure.net> and others.