summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..62c4dda
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+%:
+ dh ${@} --with apache2
+
+override_dh_auto_install:
+ # apache-tools
+ $(MAKE) -C apache DESTDIR=$(CURDIR)/debian/open-infrastructure-service-tools install
+
+ # service-tools
+ rm -f debian/open-infrastructure-service-tools/usr/share/doc/service-tools/CHANGELOG.txt
+ rm -f debian/open-infrastructure-service-tools/usr/share/doc/service-tools/LICENSE.txt
+ -mv debian/open-infrastructure-service-tools/usr/share/doc/* debian/open-infrastructure-service-tools/usr/share/doc/open-infrastructure-service-tools