summaryrefslogtreecommitdiffstats
path: root/libraries/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/Makefile.in')
-rw-r--r--libraries/Makefile.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/libraries/Makefile.in b/libraries/Makefile.in
new file mode 100644
index 0000000..b3a9127
--- /dev/null
+++ b/libraries/Makefile.in
@@ -0,0 +1,30 @@
+# Libraries Makefile for OpenLDAP
+# $OpenLDAP$
+## This work is part of OpenLDAP Software <http://www.openldap.org/>.
+##
+## Copyright 1998-2022 The OpenLDAP Foundation.
+## All rights reserved.
+##
+## Redistribution and use in source and binary forms, with or without
+## modification, are permitted only as authorized by the OpenLDAP
+## Public License.
+##
+## A copy of this license is available in the file LICENSE in the
+## top-level directory of the distribution or, alternatively, at
+## <http://www.OpenLDAP.org/license.html>.
+
+SUBDIRS= \
+ liblutil \
+ liblber \
+ liblunicode \
+ libldap \
+ librewrite
+
+PKGCONFIG_DIR=$(DESTDIR)$(libdir)/pkgconfig
+PKGCONFIG_SRCDIRS=liblber libldap
+
+install-local:
+ @-$(MKDIR) $(PKGCONFIG_DIR)
+ @for i in $(PKGCONFIG_SRCDIRS); do \
+ $(INSTALL_DATA) $$i/*.pc $(PKGCONFIG_DIR); \
+ done