summaryrefslogtreecommitdiffstats
path: root/debian/keygen-test
diff options
context:
space:
mode:
Diffstat (limited to 'debian/keygen-test')
-rw-r--r--debian/keygen-test/Makefile12
-rw-r--r--debian/keygen-test/getpid.c39
-rwxr-xr-xdebian/keygen-test/keygen-test12
3 files changed, 63 insertions, 0 deletions
diff --git a/debian/keygen-test/Makefile b/debian/keygen-test/Makefile
new file mode 100644
index 0000000..71f5eb8
--- /dev/null
+++ b/debian/keygen-test/Makefile
@@ -0,0 +1,12 @@
+test: getpid.so
+ chmod +x keygen-test
+ ./keygen-test
+
+getpid.o: getpid.c
+ gcc $(CPPFLAGS) $(CFLAGS) -fPIC -c $< -o $@
+
+getpid.so: getpid.o
+ gcc $(LDFLAGS) -shared -o $@ $<
+
+clean:
+ rm -f getpid.o getpid.so key1 key1.pub key2 key2.pub
diff --git a/debian/keygen-test/getpid.c b/debian/keygen-test/getpid.c
new file mode 100644
index 0000000..c9e35b8
--- /dev/null
+++ b/debian/keygen-test/getpid.c
@@ -0,0 +1,39 @@
+/*
+ * Compile:
+
+gcc -fPIC -c getpid.c -o getpid.o
+gcc -shared -o getpid.so getpid.o
+
+ * Use:
+
+FORCE_PID=1234 LD_PRELOAD=./getpid.so bash
+
+#
+# Copyright (C) 2001-2008 Kees Cook
+# kees@outflux.net, http://outflux.net/
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+# http://www.gnu.org/copyleft/gpl.html
+
+*/
+
+#include <sys/types.h>
+#include <unistd.h>
+#include <stdlib.h>
+
+pid_t getpid(void)
+{
+ return atoi(getenv("FORCE_PID"));
+}
diff --git a/debian/keygen-test/keygen-test b/debian/keygen-test/keygen-test
new file mode 100755
index 0000000..2abe815
--- /dev/null
+++ b/debian/keygen-test/keygen-test
@@ -0,0 +1,12 @@
+#! /bin/sh
+
+rm -f key1 key1.pub key2 key2.pub
+LD_PRELOAD="$(pwd)/getpid.so" FORCE_PID=1234 \
+ ../build-deb/ssh-keygen -N '' -f key1 >/dev/null
+LD_PRELOAD="$(pwd)/getpid.so" FORCE_PID=1234 \
+ ../build-deb/ssh-keygen -N '' -f key2 >/dev/null
+if cmp -s key1 key2; then
+ echo "Generated two identical keys!" >&2
+ exit 1
+fi
+exit 0