summaryrefslogtreecommitdiffstats
path: root/spa/plugins/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:28:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 18:28:17 +0000
commit7a46c07230b8d8108c0e8e80df4522d0ac116538 (patch)
treed483300dab478b994fe199a5d19d18d74153718a /spa/plugins/meson.build
parentInitial commit. (diff)
downloadpipewire-7a46c07230b8d8108c0e8e80df4522d0ac116538.tar.xz
pipewire-7a46c07230b8d8108c0e8e80df4522d0ac116538.zip
Adding upstream version 0.3.65.upstream/0.3.65upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'spa/plugins/meson.build')
-rw-r--r--spa/plugins/meson.build58
1 files changed, 58 insertions, 0 deletions
diff --git a/spa/plugins/meson.build b/spa/plugins/meson.build
new file mode 100644
index 0000000..d641dd8
--- /dev/null
+++ b/spa/plugins/meson.build
@@ -0,0 +1,58 @@
+if alsa_dep.found()
+ subdir('alsa')
+endif
+if get_option('avb').require(host_machine.system() == 'linux', error_message: 'AVB support is only available on Linux').allowed()
+ subdir('avb')
+endif
+if get_option('audioconvert').allowed()
+ subdir('audioconvert')
+endif
+if get_option('audiomixer').allowed()
+ subdir('audiomixer')
+endif
+if get_option('control').allowed()
+ subdir('control')
+endif
+if get_option('audiotestsrc').allowed()
+ subdir('audiotestsrc')
+endif
+if bluez_deps_found
+ subdir('bluez5')
+endif
+if avcodec_dep.found()
+ subdir('ffmpeg')
+endif
+if jack_dep.found()
+ subdir('jack')
+endif
+if get_option('support').allowed()
+ subdir('support')
+endif
+if get_option('test').allowed()
+ subdir('test')
+endif
+if get_option('videoconvert').allowed()
+ subdir('videoconvert')
+endif
+if get_option('videotestsrc').allowed()
+ subdir('videotestsrc')
+endif
+if get_option('volume').allowed()
+ subdir('volume')
+endif
+if vulkan_headers
+ subdir('vulkan')
+endif
+
+v4l2_header_found = cc.has_header('linux/videodev2.h', required: get_option('v4l2'))
+v4l2_supported = libudev_dep.found() and v4l2_header_found
+summary({'V4L2 kernel header': v4l2_header_found}, bool_yn: true, section: 'Backend')
+summary({'V4L2 enabled': v4l2_supported}, bool_yn: true, section: 'Backend')
+if v4l2_supported
+ subdir('v4l2')
+endif
+if libcamera_dep.found()
+ subdir('libcamera')
+endif
+
+subdir('aec')