summaryrefslogtreecommitdiffstats
path: root/spa/plugins/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'spa/plugins/test/meson.build')
-rw-r--r--spa/plugins/test/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/spa/plugins/test/meson.build b/spa/plugins/test/meson.build
new file mode 100644
index 0000000..950ee7c
--- /dev/null
+++ b/spa/plugins/test/meson.build
@@ -0,0 +1,7 @@
+test_sources = ['fakesrc.c', 'fakesink.c', 'plugin.c']
+
+testlib = shared_library('spa-test',
+ test_sources,
+ dependencies : [ spa_dep, pthread_lib ],
+ install : true,
+ install_dir : spa_plugindir / 'test')