summaryrefslogtreecommitdiffstats
path: root/t/foo/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 16:02:19 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 16:02:19 +0000
commite308bcff5a610d6a3bbe33b3769f03f6d4533b16 (patch)
tree6a8ed4eb26cd55f3a24165bc1d9b9a1f0ab62e8c /t/foo/Makefile
parentInitial commit. (diff)
downloadpostgresql-common-e308bcff5a610d6a3bbe33b3769f03f6d4533b16.tar.xz
postgresql-common-e308bcff5a610d6a3bbe33b3769f03f6d4533b16.zip
Adding upstream version 248.upstream/248upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/foo/Makefile')
-rw-r--r--t/foo/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/t/foo/Makefile b/t/foo/Makefile
new file mode 100644
index 0000000..75e95e1
--- /dev/null
+++ b/t/foo/Makefile
@@ -0,0 +1,12 @@
+TAR = foo_123.orig.tar.gz
+
+test: $(TAR)
+ cd foo-123 && echo y | EDITOR=true dh_make_pgxs
+ cd foo-123 && dpkg-buildpackage -us -uc
+
+tar $(TAR):
+ tar cfz $(TAR) foo-123/
+
+clean:
+ rm -f *.*
+ rm -rf foo-123/build-* foo-123/debian foo-123/*.o*