summaryrefslogtreecommitdiffstats
path: root/debhelper/Debian/Debhelper/Sequence/pgxs.pm
diff options
context:
space:
mode:
Diffstat (limited to 'debhelper/Debian/Debhelper/Sequence/pgxs.pm')
-rw-r--r--debhelper/Debian/Debhelper/Sequence/pgxs.pm22
1 files changed, 22 insertions, 0 deletions
diff --git a/debhelper/Debian/Debhelper/Sequence/pgxs.pm b/debhelper/Debian/Debhelper/Sequence/pgxs.pm
new file mode 100644
index 0000000..45a1ff1
--- /dev/null
+++ b/debhelper/Debian/Debhelper/Sequence/pgxs.pm
@@ -0,0 +1,22 @@
+#!/usr/bin/perl
+
+use warnings;
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+# check if debian/control needs updating from debian/control.in
+insert_after("dh_clean", "pg_buildext");
+add_command_options("pg_buildext", "checkcontrol");
+
+# use PGXS for clean, build, and install
+add_command_options("dh_auto_clean", "--buildsystem=pgxs");
+add_command_options("dh_auto_build", "--buildsystem=pgxs");
+add_command_options("dh_auto_install", "--buildsystem=pgxs");
+
+# move tests from dh_auto_test to dh_pgxs_test
+remove_command("dh_auto_test");
+if (! get_buildoption("nocheck")) {
+ insert_after("dh_link", "dh_pgxs_test");
+}
+
+1;