summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..b4e10d2
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+# vim:fileencoding=utf-8:noet
+
+from setuptools import setup
+
+setup(
+ name = 'powerline-gitstatus',
+ description = 'A Powerline segment for showing the status of a Git working copy',
+ version = '1.3.1',
+ keywords = 'powerline git status prompt',
+ license = 'MIT',
+ author = 'Jasper N. Brouwer',
+ author_email = 'jasper@nerdsweide.nl',
+ url = 'https://github.com/jaspernbrouwer/powerline-gitstatus',
+ packages = ['powerline_gitstatus'],
+ classifiers = [
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Topic :: Terminals'
+ ]
+)