summaryrefslogtreecommitdiffstats
path: root/debian/patches/0003-add_powerline_compile_flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0003-add_powerline_compile_flags.patch')
-rw-r--r--debian/patches/0003-add_powerline_compile_flags.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/patches/0003-add_powerline_compile_flags.patch b/debian/patches/0003-add_powerline_compile_flags.patch
new file mode 100644
index 0000000..955824e
--- /dev/null
+++ b/debian/patches/0003-add_powerline_compile_flags.patch
@@ -0,0 +1,20 @@
+Author: Jerome Charaoui <jerome@riseup.net>
+Description: Adds CPPFLAGS and LDFLAGS to scripts/powerline compiler
+Forwarded: not-needed
+
+diff -Naurp powerline.orig/setup.py powerline/setup.py
+--- powerline.orig/setup.py
++++ powerline/setup.py
+@@ -30,9 +30,11 @@ def compile_client():
+ from distutils.ccompiler import new_compiler
+ compiler = new_compiler().compiler
+ cflags = os.environ.get('CFLAGS', str('-O3'))
++ ldflags = os.environ.get('LDFLAGS', '')
++ cppflags = os.environ.get('CPPFLAGS', '')
+ # A normal split would do a split on each space which might be incorrect. The
+ # shlex will not split if a space occurs in an arguments value.
+- subprocess.check_call(compiler + shlex.split(cflags) + ['client/powerline.c', '-o', 'scripts/powerline'])
++ subprocess.check_call(compiler + shlex.split(cflags) + shlex.split(ldflags) + shlex.split(cppflags) + ['client/powerline.c', '-o', 'scripts/powerline'])
+
+ try:
+ compile_client()