summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 16:55:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 16:55:34 +0000
commit75417f5e3d32645859d94cec82255dc130ec4a2e (patch)
tree5fd46925c6b4a881c9208772ed8e5cc0588bc164 /Makefile
parentInitial commit. (diff)
downloadprivacybadger-75417f5e3d32645859d94cec82255dc130ec4a2e.tar.xz
privacybadger-75417f5e3d32645859d94cec82255dc130ec4a2e.zip
Adding upstream version 2020.10.7.upstream/2020.10.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..10cc956
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,35 @@
+lint:
+ ./node_modules/.bin/eslint .
+
+updatepsl:
+ scripts/updatepsl.sh
+
+updateseed:
+ scripts/updateseeddata.sh
+
+updategoogle:
+ scripts/updategoogle.sh
+
+todo:
+ grep -rn 'TODO' src
+
+upload:
+ $(eval TMPFILE := $(shell mktemp))
+ scp src/data/yellowlist.txt $$YELLOWLIST_UPLOAD_PATH
+ scripts/generate-legacy-yellowlist.sh > $(TMPFILE) && scp $(TMPFILE) $$YELLOWLIST_LEGACY_UPLOAD_PATH && rm $(TMPFILE)
+ scp src/data/dnt-policies.json $$DNT_POLICIES_UPLOAD_PATH
+
+tx:
+ tx pull -f
+ scripts/fix_placeholders.py
+
+runch:
+ ./node_modules/.bin/web-ext run --target chromium --start-url "chrome://extensions" -s src/
+
+runff:
+ ./node_modules/.bin/web-ext run --start-url "about:debugging#/runtime/this-firefox" -s src/
+
+runfn:
+ ./node_modules/.bin/web-ext run --start-url "about:debugging#/runtime/this-firefox" -s src/ -f nightly
+
+.PHONY: lint updatepsl updateseed updategoogle todo tx runch runff runfn