summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..10cc956
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,35 @@
+lint:
+ ./node_modules/.bin/eslint .
+
+updatepsl:
+ scripts/updatepsl.sh
+
+updateseed:
+ scripts/updateseeddata.sh
+
+updategoogle:
+ scripts/updategoogle.sh
+
+todo:
+ grep -rn 'TODO' src
+
+upload:
+ $(eval TMPFILE := $(shell mktemp))
+ scp src/data/yellowlist.txt $$YELLOWLIST_UPLOAD_PATH
+ scripts/generate-legacy-yellowlist.sh > $(TMPFILE) && scp $(TMPFILE) $$YELLOWLIST_LEGACY_UPLOAD_PATH && rm $(TMPFILE)
+ scp src/data/dnt-policies.json $$DNT_POLICIES_UPLOAD_PATH
+
+tx:
+ tx pull -f
+ scripts/fix_placeholders.py
+
+runch:
+ ./node_modules/.bin/web-ext run --target chromium --start-url "chrome://extensions" -s src/
+
+runff:
+ ./node_modules/.bin/web-ext run --start-url "about:debugging#/runtime/this-firefox" -s src/
+
+runfn:
+ ./node_modules/.bin/web-ext run --start-url "about:debugging#/runtime/this-firefox" -s src/ -f nightly
+
+.PHONY: lint updatepsl updateseed updategoogle todo tx runch runff runfn