summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Readline-8.2-patch-1-fix-crash-when-readline-is-star.patch20
-rw-r--r--debian/patches/configure-tinfo.diff108
-rw-r--r--debian/patches/examples-makefile-multiarch.diff30
-rw-r--r--debian/patches/fix-wformat-security.diff16
-rw-r--r--debian/patches/rl-attribute.diff32
-rw-r--r--debian/patches/rl-header.diff24
-rw-r--r--debian/patches/rl-no-cross-check.diff15
-rw-r--r--debian/patches/rl-no-rpath.diff15
-rw-r--r--debian/patches/rlfe-history.diff50
-rw-r--r--debian/patches/rlfe-kfreebsd.diff11
-rw-r--r--debian/patches/rlfe-signal-rvt.diff11
-rw-r--r--debian/patches/rlfe-tinfo.diff444
-rw-r--r--debian/patches/series13
13 files changed, 789 insertions, 0 deletions
diff --git a/debian/patches/0001-Readline-8.2-patch-1-fix-crash-when-readline-is-star.patch b/debian/patches/0001-Readline-8.2-patch-1-fix-crash-when-readline-is-star.patch
new file mode 100644
index 0000000..2bf29da
--- /dev/null
+++ b/debian/patches/0001-Readline-8.2-patch-1-fix-crash-when-readline-is-star.patch
@@ -0,0 +1,20 @@
+From 7274faabe97ce53d6b464272d7e6ab6c1392837b Mon Sep 17 00:00:00 2001
+From: Chet Ramey <chet.ramey@case.edu>
+Date: Wed, 5 Oct 2022 10:41:16 -0400
+Subject: Readline-8.2 patch 1: fix crash when readline is started with an
+ invalid locale specification
+
+--- a/nls.c
++++ b/nls.c
+@@ -141,6 +141,10 @@ _rl_init_locale (void)
+ if (lspec == 0)
+ lspec = "";
+ ret = setlocale (LC_CTYPE, lspec); /* ok, since it does not change locale */
++ if (ret == 0 || *ret == 0)
++ ret = setlocale (LC_CTYPE, (char *)NULL);
++ if (ret == 0 || *ret == 0)
++ ret = RL_DEFAULT_LOCALE;
+ #else
+ ret = (lspec == 0 || *lspec == 0) ? RL_DEFAULT_LOCALE : lspec;
+ #endif
+
diff --git a/debian/patches/configure-tinfo.diff b/debian/patches/configure-tinfo.diff
new file mode 100644
index 0000000..775d816
--- /dev/null
+++ b/debian/patches/configure-tinfo.diff
@@ -0,0 +1,108 @@
+--- a/aclocal.m4
++++ b/aclocal.m4
+@@ -963,8 +963,8 @@ _bash_needmsg=
+ fi
+ AC_CACHE_VAL(bash_cv_termcap_lib,
+ [AC_CHECK_FUNC(tgetent, bash_cv_termcap_lib=libc,
+- [AC_CHECK_LIB(termcap, tgetent, bash_cv_termcap_lib=libtermcap,
+- [AC_CHECK_LIB(tinfo, tgetent, bash_cv_termcap_lib=libtinfo,
++ [AC_CHECK_LIB(tinfo, tgetent, bash_cv_termcap_lib=libtinfo,
++ [AC_CHECK_LIB(termcap, tgetent, bash_cv_termcap_lib=libtermcap,
+ [AC_CHECK_LIB(curses, tgetent, bash_cv_termcap_lib=libcurses,
+ [AC_CHECK_LIB(ncurses, tgetent, bash_cv_termcap_lib=libncurses,
+ [AC_CHECK_LIB(ncursesw, tgetent, bash_cv_termcap_lib=libncursesw,
+--- a/configure
++++ b/configure
+@@ -3758,7 +3758,7 @@ ac_clean_files="$ac_clean_files conftest
+ # the compiler is broken, or we cross compile.
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking whether we are cross compiling" >&5
+ printf %s "checking whether we are cross compiling... " >&6; }
+-if false && test "$cross_compiling" != yes; then
++if test "$cross_compiling" != yes; then
+ { { ac_try="$ac_link"
+ case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
+@@ -7076,14 +7076,14 @@ if test "x$ac_cv_func_tgetent" = xyes
+ then :
+ bash_cv_termcap_lib=libc
+ else $as_nop
+- { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for tgetent in -ltermcap" >&5
+-printf %s "checking for tgetent in -ltermcap... " >&6; }
+-if test ${ac_cv_lib_termcap_tgetent+y}
++ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for tgetent in -ltinfo" >&5
++printf %s "checking for tgetent in -ltinfo... " >&6; }
++if test ${ac_cv_lib_tinfo_tgetent+y}
+ then :
+ printf %s "(cached) " >&6
+ else $as_nop
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-ltermcap $LIBS"
++LIBS="-ltinfo $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -7101,28 +7101,28 @@ return tgetent ();
+ _ACEOF
+ if ac_fn_c_try_link "$LINENO"
+ then :
+- ac_cv_lib_termcap_tgetent=yes
++ ac_cv_lib_tinfo_tgetent=yes
+ else $as_nop
+- ac_cv_lib_termcap_tgetent=no
++ ac_cv_lib_tinfo_tgetent=no
+ fi
+ rm -f core conftest.err conftest.$ac_objext conftest.beam \
+ conftest$ac_exeext conftest.$ac_ext
+ LIBS=$ac_check_lib_save_LIBS
+ fi
+-{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_termcap_tgetent" >&5
+-printf "%s\n" "$ac_cv_lib_termcap_tgetent" >&6; }
+-if test "x$ac_cv_lib_termcap_tgetent" = xyes
++{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_tinfo_tgetent" >&5
++printf "%s\n" "$ac_cv_lib_tinfo_tgetent" >&6; }
++if test "x$ac_cv_lib_tinfo_tgetent" = xyes
+ then :
+- bash_cv_termcap_lib=libtermcap
++ bash_cv_termcap_lib=libtinfo
+ else $as_nop
+- { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for tgetent in -ltinfo" >&5
+-printf %s "checking for tgetent in -ltinfo... " >&6; }
+-if test ${ac_cv_lib_tinfo_tgetent+y}
++ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for tgetent in -ltermcap" >&5
++printf %s "checking for tgetent in -ltermcap... " >&6; }
++if test ${ac_cv_lib_termcap_tgetent+y}
+ then :
+ printf %s "(cached) " >&6
+ else $as_nop
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-ltinfo $LIBS"
++LIBS="-ltermcap $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -7140,19 +7140,19 @@ return tgetent ();
+ _ACEOF
+ if ac_fn_c_try_link "$LINENO"
+ then :
+- ac_cv_lib_tinfo_tgetent=yes
++ ac_cv_lib_termcap_tgetent=yes
+ else $as_nop
+- ac_cv_lib_tinfo_tgetent=no
++ ac_cv_lib_termcap_tgetent=no
+ fi
+ rm -f core conftest.err conftest.$ac_objext conftest.beam \
+ conftest$ac_exeext conftest.$ac_ext
+ LIBS=$ac_check_lib_save_LIBS
+ fi
+-{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_tinfo_tgetent" >&5
+-printf "%s\n" "$ac_cv_lib_tinfo_tgetent" >&6; }
+-if test "x$ac_cv_lib_tinfo_tgetent" = xyes
++{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_termcap_tgetent" >&5
++printf "%s\n" "$ac_cv_lib_termcap_tgetent" >&6; }
++if test "x$ac_cv_lib_termcap_tgetent" = xyes
+ then :
+- bash_cv_termcap_lib=libtinfo
++ bash_cv_termcap_lib=libtermcap
+ else $as_nop
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for tgetent in -lcurses" >&5
+ printf %s "checking for tgetent in -lcurses... " >&6; }
diff --git a/debian/patches/examples-makefile-multiarch.diff b/debian/patches/examples-makefile-multiarch.diff
new file mode 100644
index 0000000..d2c11e3
--- /dev/null
+++ b/debian/patches/examples-makefile-multiarch.diff
@@ -0,0 +1,30 @@
+From e5a01df4f075ddb96c393748d37a16498aa37c0a Mon Sep 17 00:00:00 2001
+From: Shawn Landden <shawnlandden@gmail.com>
+Date: Wed, 18 Jul 2012 18:21:14 -0700
+Subject: [PATCH] fix Makefile -- allows build of examples, multi-arch: same
+
+---
+ examples/Makefile.in | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+Index: b/examples/Makefile.in
+===================================================================
+--- a/examples/Makefile.in
++++ b/examples/Makefile.in
+@@ -27,12 +27,12 @@
+ datarootdir = @datarootdir@
+
+ bindir = @bindir@
+-srcdir = @srcdir@
++srcdir = /usr/share/doc/libreadline6/examples
+ datadir = @datadir@
+-VPATH = @srcdir@
+-top_srcdir = @top_srcdir@
++VPATH = .:/usr/share/doc/libreadline6/examples
++top_srcdir = /usr/include/readline
+ #BUILD_DIR = .
+-BUILD_DIR = @BUILD_DIR@
++BUILD_DIR = /usr/src/readline6/build
+ installdir = $(datadir)/readline
+
+ INSTALL = @INSTALL@
diff --git a/debian/patches/fix-wformat-security.diff b/debian/patches/fix-wformat-security.diff
new file mode 100644
index 0000000..5fb71a2
--- /dev/null
+++ b/debian/patches/fix-wformat-security.diff
@@ -0,0 +1,16 @@
+Description: Fix compiling with -Werror=format-security.
+ Prevents format string attacks.
+Author: Simon Ruderich <simon@ruderich.org>
+Last-Update: 2012-09-15
+
+--- a/examples/rlfe/rlfe.c
++++ b/examples/rlfe/rlfe.c
+@@ -273,7 +273,7 @@ static void maybe_emphasize_input (int o
+ if (on == current_emphasize_input
+ || (on && ! do_emphasize_input))
+ return;
+- fprintf (rl_outstream, on ? start_input_mode : end_input_mode);
++ fprintf (rl_outstream, "%s", on ? start_input_mode : end_input_mode);
+ fflush (rl_outstream);
+ current_emphasize_input = on;
+ }
diff --git a/debian/patches/rl-attribute.diff b/debian/patches/rl-attribute.diff
new file mode 100644
index 0000000..451c0fd
--- /dev/null
+++ b/debian/patches/rl-attribute.diff
@@ -0,0 +1,32 @@
+rl-attribute.dpatch by <doko@debian.org>
+
+Do not redefine __attribute__, define macro __rl_attribute__
+
+--- a/readline.h
++++ b/readline.h
+@@ -405,7 +405,7 @@ extern void rl_deactivate_mark (void);
+ extern int rl_mark_active_p (void);
+
+ #if defined (USE_VARARGS) && defined (PREFER_STDARG)
+-extern int rl_message (const char *, ...) __attribute__((__format__ (printf, 1, 2)));
++extern int rl_message (const char *, ...) __rl_attribute__((__format__ (printf, 1, 2)));
+ #else
+ extern int rl_message ();
+ #endif
+--- a/rlstdc.h
++++ b/rlstdc.h
+@@ -36,10 +36,10 @@
+ # endif
+ #endif
+
+-#ifndef __attribute__
+-# if __GNUC__ < 2 || (__GNUC__ == 2 && __GNUC_MINOR__ < 8)
+-# define __attribute__(x)
+-# endif
++#if defined(__GNUC__) && __GNUC__ >= 2
++# define __rl_attribute__(x) __attribute__(x)
++#else
++# define __rl_attribute__(x)
+ #endif
+
+ /* Moved from config.h.in because readline.h:rl_message depends on these
diff --git a/debian/patches/rl-header.diff b/debian/patches/rl-header.diff
new file mode 100644
index 0000000..7695081
--- /dev/null
+++ b/debian/patches/rl-header.diff
@@ -0,0 +1,24 @@
+rl-header.dpatch by <doko@debian.org>
+
+Include stdio.h in readline.h and history.h
+
+--- a/history.h
++++ b/history.h
+@@ -32,6 +32,7 @@ extern "C" {
+ # include "rlstdc.h"
+ # include "rltypedefs.h"
+ #else
++# include <stdio.h>
+ # include <readline/rlstdc.h>
+ # include <readline/rltypedefs.h>
+ #endif
+--- a/readline.h
++++ b/readline.h
+@@ -32,6 +32,7 @@ extern "C" {
+ # include "keymaps.h"
+ # include "tilde.h"
+ #else
++# include <stdio.h>
+ # include <readline/rlstdc.h>
+ # include <readline/rltypedefs.h>
+ # include <readline/keymaps.h>
diff --git a/debian/patches/rl-no-cross-check.diff b/debian/patches/rl-no-cross-check.diff
new file mode 100644
index 0000000..757717d
--- /dev/null
+++ b/debian/patches/rl-no-cross-check.diff
@@ -0,0 +1,15 @@
+rl-no-cross-check.dpatch by <doko@debian.org>
+
+configure: Don't check for cross compilation
+
+--- a/configure
++++ b/configure
+@@ -3758,7 +3758,7 @@ ac_clean_files="$ac_clean_files conftest
+ # the compiler is broken, or we cross compile.
+ { printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking whether we are cross compiling" >&5
+ printf %s "checking whether we are cross compiling... " >&6; }
+-if test "$cross_compiling" != yes; then
++if false && test "$cross_compiling" != yes; then
+ { { ac_try="$ac_link"
+ case "(($ac_try" in
+ *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
diff --git a/debian/patches/rl-no-rpath.diff b/debian/patches/rl-no-rpath.diff
new file mode 100644
index 0000000..cdcc47d
--- /dev/null
+++ b/debian/patches/rl-no-rpath.diff
@@ -0,0 +1,15 @@
+rl-no-rpath.dpatch by <doko@debian.org>
+
+Don't set a runtime path for linking the shared libraries
+
+--- a/support/shobj-conf
++++ b/support/shobj-conf
+@@ -128,7 +128,7 @@ linux*-*|gnu*-*|k*bsd*-gnu-*|freebsd*-ge
+ SHOBJ_LD='${CC}'
+ SHOBJ_LDFLAGS='-shared -Wl,-soname,$@'
+
+- SHLIB_XLDFLAGS='-Wl,-rpath,$(libdir) -Wl,-soname,`basename $@ $(SHLIB_MINOR)`'
++ SHLIB_XLDFLAGS='-Wl,-soname,`basename $@ $(SHLIB_MINOR)`'
+ SHLIB_LIBVERSION='$(SHLIB_LIBSUFF).$(SHLIB_MAJOR)$(SHLIB_MINOR)'
+ ;;
+
diff --git a/debian/patches/rlfe-history.diff b/debian/patches/rlfe-history.diff
new file mode 100644
index 0000000..7962003
--- /dev/null
+++ b/debian/patches/rlfe-history.diff
@@ -0,0 +1,50 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## rlfe-history.dpatch by <andrew@pimlott.net>
+##
+## DP: Fix rlfe, always writing a history file.
+
+@DPATCH@
+--- a/examples/rlfe/rlfe.c
++++ b/examples/rlfe/rlfe.c
+@@ -154,21 +154,27 @@ struct termios orig_term;
+ static pid_t child = -1;
+
+ static void
+-sig_child (int signo)
++finish_up()
+ {
+- int status;
+- wait (&status);
+ if (hist_file != 0)
+ {
+ write_history (hist_file);
+ if (hist_size)
+ history_truncate_file (hist_file, hist_size);
+ }
+- DPRINT0 ("(Child process died.)\n");
+ tcsetattr(STDIN_FILENO, TCSANOW, &orig_term);
+ exit (0);
+ }
+
++static void
++sig_child (int signo)
++{
++ int status;
++ wait (&status);
++ DPRINT0 ("(Child process died.)\n");
++ finish_up();
++}
++
+ volatile int propagate_sigwinch = 0;
+
+ /* sigwinch_handler
+@@ -710,8 +716,7 @@ main(int argc, char** argv)
+ if (count <= 0)
+ {
+ DPRINT0 ("(Connection closed by foreign host.)\n");
+- tcsetattr(STDIN_FILENO, TCSANOW, &orig_term);
+- exit (0);
++ finish_up();
+ }
+ old_count = buf_count;
+
diff --git a/debian/patches/rlfe-kfreebsd.diff b/debian/patches/rlfe-kfreebsd.diff
new file mode 100644
index 0000000..ce66489
--- /dev/null
+++ b/debian/patches/rlfe-kfreebsd.diff
@@ -0,0 +1,11 @@
+--- a/examples/rlfe/pty.c
++++ b/examples/rlfe/pty.c
+@@ -133,7 +133,7 @@ int f;
+ {
+ if (f < 0)
+ return;
+-#if defined(I_PUSH) && defined(HAVE_SVR4_PTYS) && !defined(sgi) && !defined(linux) && !defined(__osf__) && !defined(M_UNIX)
++#if defined(I_PUSH) && defined(HAVE_SVR4_PTYS) && !defined(sgi) && !defined(linux) && !defined(__osf__) && !defined(M_UNIX) && !defined(__FreeBSD_kernel__)
+ if (ioctl(f, I_PUSH, "ptem"))
+ Panic(errno, "InitPTY: cannot I_PUSH ptem");
+ if (ioctl(f, I_PUSH, "ldterm"))
diff --git a/debian/patches/rlfe-signal-rvt.diff b/debian/patches/rlfe-signal-rvt.diff
new file mode 100644
index 0000000..2a95fad
--- /dev/null
+++ b/debian/patches/rlfe-signal-rvt.diff
@@ -0,0 +1,11 @@
+--- a/examples/rlfe/pty.c
++++ b/examples/rlfe/pty.c
+@@ -254,7 +254,7 @@ char **ttyn;
+ #if defined(HAVE_GETPT) && defined(linux)
+ int getpt __P((void));
+ #endif
+- sigret_t (*sigcld)__P(SIGPROTOARG);
++ sighandler_t sigcld;
+
+ strcpy(PtyName, "/dev/ptmx");
+ #if defined(HAVE_GETPT) && defined(linux)
diff --git a/debian/patches/rlfe-tinfo.diff b/debian/patches/rlfe-tinfo.diff
new file mode 100644
index 0000000..4121bbf
--- /dev/null
+++ b/debian/patches/rlfe-tinfo.diff
@@ -0,0 +1,444 @@
+# DP: Link rlfe with libtinfo.
+
+--- a/examples/rlfe/configure.in
++++ b/examples/rlfe/configure.in
+@@ -211,8 +211,8 @@ __sorry_hpux_libcurses_is_totally_broken
+ tgetent((char *)0, (char *)0);
+ #endif
+ ],,
+-LIBS="-ltermcap $olibs"
+-AC_CHECKING(libtermcap)
++LIBS="-ltinfo $olibs"
++AC_CHECKING(libtinfo)
+ AC_TRY_LINK(,tgetent((char *)0, (char *)0);,,
+ LIBS="-ltermlib $olibs"
+ AC_CHECKING(libtermlib)
+--- a/examples/rlfe/configure
++++ b/examples/rlfe/configure
+@@ -1,11 +1,9 @@
+ #! /bin/sh
+ # Guess values for system-dependent variables and create Makefiles.
+-# Generated by GNU Autoconf 2.68.
++# Generated by GNU Autoconf 2.69.
+ #
+ #
+-# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
+-# 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010 Free Software
+-# Foundation, Inc.
++# Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
+ #
+ #
+ # This configure script is free software; the Free Software Foundation
+@@ -134,6 +132,31 @@ export LANGUAGE
+ # CDPATH.
+ (unset CDPATH) >/dev/null 2>&1 && unset CDPATH
+
++# Use a proper internal environment variable to ensure we don't fall
++ # into an infinite loop, continuously re-executing ourselves.
++ if test x"${_as_can_reexec}" != xno && test "x$CONFIG_SHELL" != x; then
++ _as_can_reexec=no; export _as_can_reexec;
++ # We cannot yet assume a decent shell, so we have to provide a
++# neutralization value for shells without unset; and this also
++# works around shells that cannot unset nonexistent variables.
++# Preserve -v and -x to the replacement shell.
++BASH_ENV=/dev/null
++ENV=/dev/null
++(unset BASH_ENV) >/dev/null 2>&1 && unset BASH_ENV ENV
++case $- in # ((((
++ *v*x* | *x*v* ) as_opts=-vx ;;
++ *v* ) as_opts=-v ;;
++ *x* ) as_opts=-x ;;
++ * ) as_opts= ;;
++esac
++exec $CONFIG_SHELL $as_opts "$as_myself" ${1+"$@"}
++# Admittedly, this is quite paranoid, since all the known shells bail
++# out after a failed `exec'.
++$as_echo "$0: could not re-execute with $CONFIG_SHELL" >&2
++as_fn_exit 255
++ fi
++ # We don't want this to propagate to other subprocesses.
++ { _as_can_reexec=; unset _as_can_reexec;}
+ if test "x$CONFIG_SHELL" = x; then
+ as_bourne_compatible="if test -n \"\${ZSH_VERSION+set}\" && (emulate sh) >/dev/null 2>&1; then :
+ emulate sh
+@@ -167,7 +190,8 @@ if ( set x; as_fn_ret_success y && test
+ else
+ exitcode=1; echo positional parameters were not saved.
+ fi
+-test x\$exitcode = x0 || exit 1"
++test x\$exitcode = x0 || exit 1
++test -x / || exit 1"
+ as_suggested=" as_lineno_1=";as_suggested=$as_suggested$LINENO;as_suggested=$as_suggested" as_lineno_1a=\$LINENO
+ as_lineno_2=";as_suggested=$as_suggested$LINENO;as_suggested=$as_suggested" as_lineno_2a=\$LINENO
+ eval 'test \"x\$as_lineno_1'\$as_run'\" != \"x\$as_lineno_2'\$as_run'\" &&
+@@ -212,21 +236,25 @@ IFS=$as_save_IFS
+
+
+ if test "x$CONFIG_SHELL" != x; then :
+- # We cannot yet assume a decent shell, so we have to provide a
+- # neutralization value for shells without unset; and this also
+- # works around shells that cannot unset nonexistent variables.
+- # Preserve -v and -x to the replacement shell.
+- BASH_ENV=/dev/null
+- ENV=/dev/null
+- (unset BASH_ENV) >/dev/null 2>&1 && unset BASH_ENV ENV
+- export CONFIG_SHELL
+- case $- in # ((((
+- *v*x* | *x*v* ) as_opts=-vx ;;
+- *v* ) as_opts=-v ;;
+- *x* ) as_opts=-x ;;
+- * ) as_opts= ;;
+- esac
+- exec "$CONFIG_SHELL" $as_opts "$as_myself" ${1+"$@"}
++ export CONFIG_SHELL
++ # We cannot yet assume a decent shell, so we have to provide a
++# neutralization value for shells without unset; and this also
++# works around shells that cannot unset nonexistent variables.
++# Preserve -v and -x to the replacement shell.
++BASH_ENV=/dev/null
++ENV=/dev/null
++(unset BASH_ENV) >/dev/null 2>&1 && unset BASH_ENV ENV
++case $- in # ((((
++ *v*x* | *x*v* ) as_opts=-vx ;;
++ *v* ) as_opts=-v ;;
++ *x* ) as_opts=-x ;;
++ * ) as_opts= ;;
++esac
++exec $CONFIG_SHELL $as_opts "$as_myself" ${1+"$@"}
++# Admittedly, this is quite paranoid, since all the known shells bail
++# out after a failed `exec'.
++$as_echo "$0: could not re-execute with $CONFIG_SHELL" >&2
++exit 255
+ fi
+
+ if test x$as_have_required = xno; then :
+@@ -328,6 +356,14 @@ $as_echo X"$as_dir" |
+
+
+ } # as_fn_mkdir_p
++
++# as_fn_executable_p FILE
++# -----------------------
++# Test if FILE is an executable regular file.
++as_fn_executable_p ()
++{
++ test -f "$1" && test -x "$1"
++} # as_fn_executable_p
+ # as_fn_append VAR VALUE
+ # ----------------------
+ # Append the text in VALUE to the end of the definition contained in VAR. Take
+@@ -449,6 +485,10 @@ as_cr_alnum=$as_cr_Letters$as_cr_digits
+ chmod +x "$as_me.lineno" ||
+ { $as_echo "$as_me: error: cannot create $as_me.lineno; rerun with a POSIX shell" >&2; as_fn_exit 1; }
+
++ # If we had to re-execute with $CONFIG_SHELL, we're ensured to have
++ # already done that, so ensure we don't try to do so again and fall
++ # in an infinite loop. This has already happened in practice.
++ _as_can_reexec=no; export _as_can_reexec
+ # Don't try to exec as it changes $[0], causing all sort of problems
+ # (the dirname of $[0] is not the place where we might find the
+ # original and so on. Autoconf is especially sensitive to this).
+@@ -483,16 +523,16 @@ if (echo >conf$$.file) 2>/dev/null; then
+ # ... but there are two gotchas:
+ # 1) On MSYS, both `ln -s file dir' and `ln file dir' fail.
+ # 2) DJGPP < 2.04 has no symlinks; `ln -s' creates a wrapper executable.
+- # In both cases, we have to default to `cp -p'.
++ # In both cases, we have to default to `cp -pR'.
+ ln -s conf$$.file conf$$.dir 2>/dev/null && test ! -f conf$$.exe ||
+- as_ln_s='cp -p'
++ as_ln_s='cp -pR'
+ elif ln conf$$.file conf$$ 2>/dev/null; then
+ as_ln_s=ln
+ else
+- as_ln_s='cp -p'
++ as_ln_s='cp -pR'
+ fi
+ else
+- as_ln_s='cp -p'
++ as_ln_s='cp -pR'
+ fi
+ rm -f conf$$ conf$$.exe conf$$.dir/conf$$.file conf$$.file
+ rmdir conf$$.dir 2>/dev/null
+@@ -504,28 +544,8 @@ else
+ as_mkdir_p=false
+ fi
+
+-if test -x / >/dev/null 2>&1; then
+- as_test_x='test -x'
+-else
+- if ls -dL / >/dev/null 2>&1; then
+- as_ls_L_option=L
+- else
+- as_ls_L_option=
+- fi
+- as_test_x='
+- eval sh -c '\''
+- if test -d "$1"; then
+- test -d "$1/.";
+- else
+- case $1 in #(
+- -*)set "./$1";;
+- esac;
+- case `ls -ld'$as_ls_L_option' "$1" 2>/dev/null` in #((
+- ???[sx]*):;;*)false;;esac;fi
+- '\'' sh
+- '
+-fi
+-as_executable_p=$as_test_x
++as_test_x='test -x'
++as_executable_p=as_fn_executable_p
+
+ # Sed expression to map a string onto a valid CPP name.
+ as_tr_cpp="eval sed 'y%*$as_cr_letters%P$as_cr_LETTERS%;s%[^_$as_cr_alnum]%_%g'"
+@@ -1123,8 +1143,6 @@ target=$target_alias
+ if test "x$host_alias" != x; then
+ if test "x$build_alias" = x; then
+ cross_compiling=maybe
+- $as_echo "$as_me: WARNING: if you wanted to set the --build type, don't use --host.
+- If a cross compiler is detected then cross compile mode will be used" >&2
+ elif test "x$build_alias" != "x$host_alias"; then
+ cross_compiling=yes
+ fi
+@@ -1356,9 +1374,9 @@ test -n "$ac_init_help" && exit $ac_stat
+ if $ac_init_version; then
+ cat <<\_ACEOF
+ configure
+-generated by GNU Autoconf 2.68
++generated by GNU Autoconf 2.69
+
+-Copyright (C) 2010 Free Software Foundation, Inc.
++Copyright (C) 2012 Free Software Foundation, Inc.
+ This configure script is free software; the Free Software Foundation
+ gives unlimited permission to copy, distribute and modify it.
+ _ACEOF
+@@ -1471,7 +1489,7 @@ $as_echo "$ac_try_echo"; } >&5
+ test ! -s conftest.err
+ } && test -s conftest$ac_exeext && {
+ test "$cross_compiling" = yes ||
+- $as_test_x conftest$ac_exeext
++ test -x conftest$ac_exeext
+ }; then :
+ ac_retval=0
+ else
+@@ -1721,7 +1739,7 @@ This file contains any messages produced
+ running configure, to aid debugging if configure makes a mistake.
+
+ It was created by $as_me, which was
+-generated by GNU Autoconf 2.68. Invocation command line was
++generated by GNU Autoconf 2.69. Invocation command line was
+
+ $ $0 $@
+
+@@ -2097,7 +2115,7 @@ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_prog_CC="${ac_tool_prefix}gcc"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+@@ -2137,7 +2155,7 @@ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_prog_ac_ct_CC="gcc"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+@@ -2190,7 +2208,7 @@ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_prog_CC="${ac_tool_prefix}cc"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+@@ -2231,7 +2249,7 @@ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ if test "$as_dir/$ac_word$ac_exec_ext" = "/usr/ucb/cc"; then
+ ac_prog_rejected=yes
+ continue
+@@ -2289,7 +2307,7 @@ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_prog_CC="$ac_tool_prefix$ac_prog"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+@@ -2333,7 +2351,7 @@ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_prog_ac_ct_CC="$ac_prog"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+@@ -2779,8 +2797,7 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_
+ /* end confdefs.h. */
+ #include <stdarg.h>
+ #include <stdio.h>
+-#include <sys/types.h>
+-#include <sys/stat.h>
++struct stat;
+ /* Most of the following tests are stolen from RCS 5.7's src/conf.sh. */
+ struct buf { int x; };
+ FILE * (*rcsopen) (struct buf *, struct stat *, int);
+@@ -3020,7 +3037,7 @@ do
+ for ac_prog in grep ggrep; do
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ ac_path_GREP="$as_dir/$ac_prog$ac_exec_ext"
+- { test -f "$ac_path_GREP" && $as_test_x "$ac_path_GREP"; } || continue
++ as_fn_executable_p "$ac_path_GREP" || continue
+ # Check for GNU ac_path_GREP and select it if it is found.
+ # Check for GNU $ac_path_GREP
+ case `"$ac_path_GREP" --version 2>&1` in
+@@ -3086,7 +3103,7 @@ do
+ for ac_prog in egrep; do
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ ac_path_EGREP="$as_dir/$ac_prog$ac_exec_ext"
+- { test -f "$ac_path_EGREP" && $as_test_x "$ac_path_EGREP"; } || continue
++ as_fn_executable_p "$ac_path_EGREP" || continue
+ # Check for GNU ac_path_EGREP and select it if it is found.
+ # Check for GNU $ac_path_EGREP
+ case `"$ac_path_EGREP" --version 2>&1` in
+@@ -3331,7 +3348,7 @@ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_prog_AWK="$ac_prog"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+@@ -3608,9 +3625,9 @@ _ACEOF
+ if ac_fn_c_try_link "$LINENO"; then :
+
+ else
+- LIBS="-ltermcap $olibs"
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking libtermcap..." >&5
+-$as_echo "$as_me: checking libtermcap..." >&6;}
++ LIBS="-ltinfo $olibs"
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking libtinfo..." >&5
++$as_echo "$as_me: checking libtinfo..." >&6;}
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -3965,7 +3982,7 @@ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_WRITEPATH="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+@@ -4005,7 +4022,7 @@ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
++ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_XTERMPATH="$as_dir/$ac_word$ac_exec_ext"
+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+@@ -4757,16 +4774,16 @@ if (echo >conf$$.file) 2>/dev/null; then
+ # ... but there are two gotchas:
+ # 1) On MSYS, both `ln -s file dir' and `ln file dir' fail.
+ # 2) DJGPP < 2.04 has no symlinks; `ln -s' creates a wrapper executable.
+- # In both cases, we have to default to `cp -p'.
++ # In both cases, we have to default to `cp -pR'.
+ ln -s conf$$.file conf$$.dir 2>/dev/null && test ! -f conf$$.exe ||
+- as_ln_s='cp -p'
++ as_ln_s='cp -pR'
+ elif ln conf$$.file conf$$ 2>/dev/null; then
+ as_ln_s=ln
+ else
+- as_ln_s='cp -p'
++ as_ln_s='cp -pR'
+ fi
+ else
+- as_ln_s='cp -p'
++ as_ln_s='cp -pR'
+ fi
+ rm -f conf$$ conf$$.exe conf$$.dir/conf$$.file conf$$.file
+ rmdir conf$$.dir 2>/dev/null
+@@ -4826,28 +4843,16 @@ else
+ as_mkdir_p=false
+ fi
+
+-if test -x / >/dev/null 2>&1; then
+- as_test_x='test -x'
+-else
+- if ls -dL / >/dev/null 2>&1; then
+- as_ls_L_option=L
+- else
+- as_ls_L_option=
+- fi
+- as_test_x='
+- eval sh -c '\''
+- if test -d "$1"; then
+- test -d "$1/.";
+- else
+- case $1 in #(
+- -*)set "./$1";;
+- esac;
+- case `ls -ld'$as_ls_L_option' "$1" 2>/dev/null` in #((
+- ???[sx]*):;;*)false;;esac;fi
+- '\'' sh
+- '
+-fi
+-as_executable_p=$as_test_x
++
++# as_fn_executable_p FILE
++# -----------------------
++# Test if FILE is an executable regular file.
++as_fn_executable_p ()
++{
++ test -f "$1" && test -x "$1"
++} # as_fn_executable_p
++as_test_x='test -x'
++as_executable_p=as_fn_executable_p
+
+ # Sed expression to map a string onto a valid CPP name.
+ as_tr_cpp="eval sed 'y%*$as_cr_letters%P$as_cr_LETTERS%;s%[^_$as_cr_alnum]%_%g'"
+@@ -4869,7 +4874,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_wri
+ # values after options handling.
+ ac_log="
+ This file was extended by $as_me, which was
+-generated by GNU Autoconf 2.68. Invocation command line was
++generated by GNU Autoconf 2.69. Invocation command line was
+
+ CONFIG_FILES = $CONFIG_FILES
+ CONFIG_HEADERS = $CONFIG_HEADERS
+@@ -4931,10 +4936,10 @@ cat >>$CONFIG_STATUS <<_ACEOF || ac_writ
+ ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
+ ac_cs_version="\\
+ config.status
+-configured by $0, generated by GNU Autoconf 2.68,
++configured by $0, generated by GNU Autoconf 2.69,
+ with options \\"\$ac_cs_config\\"
+
+-Copyright (C) 2010 Free Software Foundation, Inc.
++Copyright (C) 2012 Free Software Foundation, Inc.
+ This config.status script is free software; the Free Software Foundation
+ gives unlimited permission to copy, distribute and modify it."
+
+@@ -5023,7 +5028,7 @@ fi
+ _ACEOF
+ cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
+ if \$ac_cs_recheck; then
+- set X '$SHELL' '$0' $ac_configure_args \$ac_configure_extra_args --no-create --no-recursion
++ set X $SHELL '$0' $ac_configure_args \$ac_configure_extra_args --no-create --no-recursion
+ shift
+ \$as_echo "running CONFIG_SHELL=$SHELL \$*" >&6
+ CONFIG_SHELL='$SHELL'
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..d085d88
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,13 @@
+#readline81-001.diff
+rl-attribute.diff
+rl-header.diff
+rl-no-cross-check.diff
+rl-no-rpath.diff
+rlfe-history.diff
+rlfe-kfreebsd.diff
+rlfe-tinfo.diff
+#examples-makefile-multiarch.diff
+fix-wformat-security.diff
+configure-tinfo.diff
+rlfe-signal-rvt.diff
+0001-Readline-8.2-patch-1-fix-crash-when-readline-is-star.patch