summaryrefslogtreecommitdiffstats
path: root/etc/pam.d/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'etc/pam.d/Makefile.am')
-rw-r--r--etc/pam.d/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/etc/pam.d/Makefile.am b/etc/pam.d/Makefile.am
new file mode 100644
index 0000000..38ff26a
--- /dev/null
+++ b/etc/pam.d/Makefile.am
@@ -0,0 +1,35 @@
+# This is a dummy Makefile.am to get automake work flawlessly,
+# and also cooperate to make a distribution for `make dist'
+
+pamd_files = \
+ chfn \
+ chsh \
+ groupmems \
+ login \
+ passwd
+
+pamd_acct_tools_files = \
+ chage \
+ chgpasswd \
+ chpasswd \
+ groupadd \
+ groupdel \
+ groupmod \
+ newusers \
+ useradd \
+ userdel \
+ usermod
+
+if USE_PAM
+pamddir = $(sysconfdir)/pam.d
+pamd_DATA = $(pamd_files)
+if ACCT_TOOLS_SETUID
+pamd_DATA += $(pamd_acct_tools_files)
+endif
+endif
+
+if WITH_SU
+pamd_files += su
+endif
+
+EXTRA_DIST = $(pamd_files) $(pamd_acct_tools_files)