summaryrefslogtreecommitdiffstats
path: root/src/oom/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:35:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:35:18 +0000
commitb750101eb236130cf056c675997decbac904cc49 (patch)
treea5df1a06754bdd014cb975c051c83b01c9a97532 /src/oom/meson.build
parentInitial commit. (diff)
downloadsystemd-b750101eb236130cf056c675997decbac904cc49.tar.xz
systemd-b750101eb236130cf056c675997decbac904cc49.zip
Adding upstream version 252.22.upstream/252.22upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/oom/meson.build')
-rw-r--r--src/oom/meson.build34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/oom/meson.build b/src/oom/meson.build
new file mode 100644
index 0000000..1203518
--- /dev/null
+++ b/src/oom/meson.build
@@ -0,0 +1,34 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+systemd_oomd_sources = files(
+ 'oomd-manager-bus.c',
+ 'oomd-manager-bus.h',
+ 'oomd-manager.c',
+ 'oomd-manager.h',
+ 'oomd-util.c',
+ 'oomd-util.h',
+ 'oomd.c',
+)
+
+oomctl_sources = files('oomctl.c')
+
+if conf.get('ENABLE_OOMD') == 1
+ install_data('org.freedesktop.oom1.conf',
+ install_dir : dbuspolicydir)
+
+ install_data('org.freedesktop.oom1.service',
+ install_dir : dbussystemservicedir)
+
+ if install_sysconfdir_samples
+ install_data('oomd.conf',
+ install_dir : pkgsysconfdir)
+ endif
+endif
+
+tests += [
+ [files('test-oomd-util.c',
+ 'oomd-util.c',
+ 'oomd-util.h'),
+ [],
+ [libatomic]]
+]