summaryrefslogtreecommitdiffstats
path: root/factory/templates
diff options
context:
space:
mode:
Diffstat (limited to 'factory/templates')
-rw-r--r--factory/templates/locale.conf.in3
-rw-r--r--factory/templates/meson.build11
2 files changed, 14 insertions, 0 deletions
diff --git a/factory/templates/locale.conf.in b/factory/templates/locale.conf.in
new file mode 100644
index 0000000..af93d04
--- /dev/null
+++ b/factory/templates/locale.conf.in
@@ -0,0 +1,3 @@
+# This is the fallback locale configuration provided by systemd.
+
+LANG="{{ SYSTEMD_DEFAULT_LOCALE }}"
diff --git a/factory/templates/meson.build b/factory/templates/meson.build
new file mode 100644
index 0000000..ece2c64
--- /dev/null
+++ b/factory/templates/meson.build
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+factory_etc_dir = factorydir / 'etc'
+
+custom_target(
+ 'locale.conf',
+ input : 'locale.conf.in',
+ output : 'locale.conf',
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
+ install : true,
+ install_dir : factory_etc_dir)