summaryrefslogtreecommitdiffstats
path: root/build/clang-plugin/tests/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /build/clang-plugin/tests/Makefile.in
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/clang-plugin/tests/Makefile.in')
-rw-r--r--build/clang-plugin/tests/Makefile.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/build/clang-plugin/tests/Makefile.in b/build/clang-plugin/tests/Makefile.in
new file mode 100644
index 0000000000..318c9a0261
--- /dev/null
+++ b/build/clang-plugin/tests/Makefile.in
@@ -0,0 +1,19 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/rules.mk
+
+$(OBJS): $(CLANG_PLUGIN)
+
+# Because building the objects doesn't actually build anything, create
+# a stamp file to avoid re-running the tests unless the test files or
+# the plugin changed. And since no objects are created, and not having
+# the files around makes the rule always, we create dummy files here too.
+tests-ok: $(OBJS) $(CSRCS) $(CPPSRCS) $(CLANG_PLUGIN)
+ touch $@ $(OBJS)
+
+target-objects: tests-ok
+
+# Don't actually build a library, since we don't actually build objects.
+$(LIBRARY): EXPAND_LIBS_GEN=true