summaryrefslogtreecommitdiffstats
path: root/build/rust/base64
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /build/rust/base64
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/base64')
-rw-r--r--build/rust/base64/Cargo.toml11
-rw-r--r--build/rust/base64/lib.rs42
2 files changed, 53 insertions, 0 deletions
diff --git a/build/rust/base64/Cargo.toml b/build/rust/base64/Cargo.toml
new file mode 100644
index 0000000000..ce9fdc2836
--- /dev/null
+++ b/build/rust/base64/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "base64"
+version = "0.13.999"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.base64]
+version = "0.21.0"
diff --git a/build/rust/base64/lib.rs b/build/rust/base64/lib.rs
new file mode 100644
index 0000000000..d5d4ce6af4
--- /dev/null
+++ b/build/rust/base64/lib.rs
@@ -0,0 +1,42 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub use base64::engine::general_purpose::*;
+pub use base64::DecodeError;
+use base64::Engine;
+
+// Re-implement some of the 0.13 APIs on top of 0.21
+
+pub fn decode<T: AsRef<[u8]>>(input: T) -> Result<Vec<u8>, DecodeError> {
+ STANDARD.decode(input)
+}
+
+pub fn encode<T: AsRef<[u8]>>(input: T) -> String {
+ STANDARD.encode(input)
+}
+
+pub fn decode_config<T: AsRef<[u8]>>(
+ input: T,
+ engine: GeneralPurpose,
+) -> Result<Vec<u8>, DecodeError> {
+ engine.decode(input)
+}
+
+pub fn encode_config<T: AsRef<[u8]>>(input: T, engine: GeneralPurpose) -> String {
+ engine.encode(input)
+}
+
+pub fn encode_config_slice<T: AsRef<[u8]>>(
+ input: T,
+ engine: GeneralPurpose,
+ output: &mut [u8],
+) -> usize {
+ engine
+ .encode_slice(input, output)
+ .expect("Output buffer too small")
+}
+
+pub fn encode_config_buf<T: AsRef<[u8]>>(input: T, engine: GeneralPurpose, buf: &mut String) {
+ engine.encode_string(input, buf)
+}