summaryrefslogtreecommitdiffstats
path: root/build/rust/cfg-if
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /build/rust/cfg-if
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/cfg-if')
-rw-r--r--build/rust/cfg-if/Cargo.toml11
-rw-r--r--build/rust/cfg-if/lib.rs5
2 files changed, 16 insertions, 0 deletions
diff --git a/build/rust/cfg-if/Cargo.toml b/build/rust/cfg-if/Cargo.toml
new file mode 100644
index 0000000000..fff5b54155
--- /dev/null
+++ b/build/rust/cfg-if/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "cfg-if"
+version = "0.1.999"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies]
+cfg-if = "1.0"
diff --git a/build/rust/cfg-if/lib.rs b/build/rust/cfg-if/lib.rs
new file mode 100644
index 0000000000..70c009f840
--- /dev/null
+++ b/build/rust/cfg-if/lib.rs
@@ -0,0 +1,5 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub use cfg_if::*;