summaryrefslogtreecommitdiffstats
path: root/build/rust/nix
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /build/rust/nix
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/nix')
-rw-r--r--build/rust/nix/Cargo.toml30
-rw-r--r--build/rust/nix/lib.rs5
2 files changed, 35 insertions, 0 deletions
diff --git a/build/rust/nix/Cargo.toml b/build/rust/nix/Cargo.toml
new file mode 100644
index 0000000000..3881d7c020
--- /dev/null
+++ b/build/rust/nix/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "nix"
+version = "0.24.99"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.nix]
+version = "0.26"
+default-features = false
+
+[features]
+acct = ["nix/acct"]
+aio = ["nix/aio"]
+default = ["nix/default"]
+dir = ["nix/dir"]
+env = ["nix/env"]
+event = ["nix/event"]
+feature = ["nix/feature"]
+fs = ["nix/fs"]
+hostname = ["nix/hostname"]
+inotify = ["nix/inotify"]
+ioctl = ["nix/ioctl"]
+kmod = ["nix/kmod"]
+mman = ["nix/mman"]
+mount = ["nix/mount"]
+mqueue = ["nix/mqueue"]
+net = ["nix/net"]
diff --git a/build/rust/nix/lib.rs b/build/rust/nix/lib.rs
new file mode 100644
index 0000000000..d1039ae71a
--- /dev/null
+++ b/build/rust/nix/lib.rs
@@ -0,0 +1,5 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub use nix::*;