summaryrefslogtreecommitdiffstats
path: root/build/rust/oslog
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /build/rust/oslog
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/oslog')
-rw-r--r--build/rust/oslog/Cargo.toml15
-rw-r--r--build/rust/oslog/LICENSE21
-rw-r--r--build/rust/oslog/lib.rs25
3 files changed, 61 insertions, 0 deletions
diff --git a/build/rust/oslog/Cargo.toml b/build/rust/oslog/Cargo.toml
new file mode 100644
index 0000000000..fa647f9646
--- /dev/null
+++ b/build/rust/oslog/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "oslog"
+version = "0.1.999"
+edition = "2018"
+license = "MIT"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.log]
+version = "0.4"
+default-features = false
+
+[features]
+logger = []
diff --git a/build/rust/oslog/LICENSE b/build/rust/oslog/LICENSE
new file mode 100644
index 0000000000..13b609c25b
--- /dev/null
+++ b/build/rust/oslog/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 Steven Joruk
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/build/rust/oslog/lib.rs b/build/rust/oslog/lib.rs
new file mode 100644
index 0000000000..4a529e7afa
--- /dev/null
+++ b/build/rust/oslog/lib.rs
@@ -0,0 +1,25 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub struct OsLogger;
+
+use log::{LevelFilter, SetLoggerError};
+
+impl OsLogger {
+ pub fn new(_subsystem: &str) -> Self {
+ Self
+ }
+
+ pub fn level_filter(self, _level: LevelFilter) -> Self {
+ self
+ }
+
+ pub fn category_level_filter(self, _category: &str, _level: LevelFilter) -> Self {
+ self
+ }
+
+ pub fn init(self) -> Result<(), SetLoggerError> {
+ Ok(())
+ }
+}