summaryrefslogtreecommitdiffstats
path: root/build/rust/vcpkg
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /build/rust/vcpkg
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/vcpkg')
-rw-r--r--build/rust/vcpkg/Cargo.toml8
-rw-r--r--build/rust/vcpkg/lib.rs23
2 files changed, 31 insertions, 0 deletions
diff --git a/build/rust/vcpkg/Cargo.toml b/build/rust/vcpkg/Cargo.toml
new file mode 100644
index 0000000000..2128be7ad8
--- /dev/null
+++ b/build/rust/vcpkg/Cargo.toml
@@ -0,0 +1,8 @@
+[package]
+name = "vcpkg"
+version = "0.2.999"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
diff --git a/build/rust/vcpkg/lib.rs b/build/rust/vcpkg/lib.rs
new file mode 100644
index 0000000000..630f19f4be
--- /dev/null
+++ b/build/rust/vcpkg/lib.rs
@@ -0,0 +1,23 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+use std::path::PathBuf;
+
+pub struct Config;
+
+pub struct Library {
+ pub include_paths: Vec<PathBuf>,
+}
+
+pub struct Error;
+
+impl Config {
+ pub fn new() -> Config {
+ Config
+ }
+
+ pub fn probe(&mut self, _: &str) -> Result<Library, Error> {
+ Err(Error)
+ }
+}