summaryrefslogtreecommitdiffstats
path: root/build/rust/wasi
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /build/rust/wasi
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/wasi')
-rw-r--r--build/rust/wasi/Cargo.toml17
-rw-r--r--build/rust/wasi/lib.rs5
2 files changed, 22 insertions, 0 deletions
diff --git a/build/rust/wasi/Cargo.toml b/build/rust/wasi/Cargo.toml
new file mode 100644
index 0000000000..e1f392a961
--- /dev/null
+++ b/build/rust/wasi/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "wasi"
+version = "0.10.0+wasi-snapshot-preview999"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.wasi]
+version = "0.11"
+default-features = false
+
+[features]
+default = ["wasi/default"]
+rustc-dep-of-std = ["wasi/rustc-dep-of-std"]
+std = ["wasi/std"]
diff --git a/build/rust/wasi/lib.rs b/build/rust/wasi/lib.rs
new file mode 100644
index 0000000000..1bb1206202
--- /dev/null
+++ b/build/rust/wasi/lib.rs
@@ -0,0 +1,5 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub use wasi::*;