summaryrefslogtreecommitdiffstats
path: root/build/win32/moz.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /build/win32/moz.build
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/win32/moz.build')
-rw-r--r--build/win32/moz.build46
1 files changed, 46 insertions, 0 deletions
diff --git a/build/win32/moz.build b/build/win32/moz.build
new file mode 100644
index 0000000000..32defa1dc8
--- /dev/null
+++ b/build/win32/moz.build
@@ -0,0 +1,46 @@
+# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+TEST_DIRS += ["crashinjectdll"]
+
+if CONFIG["ENABLE_TESTS"]:
+ Program("crashinject")
+ SOURCES += [
+ "crashinject.cpp",
+ ]
+ USE_STATIC_LIBS = True
+
+NO_PGO = True
+
+# See comment about *-windows-gnu targets in config/makefiles/rust.mk
+if CONFIG["CC_TYPE"] == "clang":
+ GeneratedFile(
+ "libgcc.a",
+ "libgcc_eh.a",
+ "libpthread.a",
+ script="dummy_libs.py",
+ flags=["libgcc_eh.a", "libpthread.a"],
+ )
+
+
+if CONFIG["WIN32_REDIST_DIR"] and CONFIG["COMPILE_ENVIRONMENT"]:
+ for f in ["MSVC_C_RUNTIME_DLL", "MSVC_C_RUNTIME_1_DLL", "MSVC_CXX_RUNTIME_DLL"]:
+ if CONFIG[f]:
+ FINAL_TARGET_FILES += ["%%%s/%s" % (CONFIG["WIN32_REDIST_DIR"], CONFIG[f])]
+
+if CONFIG["WIN_UCRT_REDIST_DIR"] and CONFIG["COMPILE_ENVIRONMENT"]:
+ win7_ucrt_redists = [
+ "api-ms-win-core-file-l1-2-0.dll",
+ "api-ms-win-core-file-l2-1-0.dll",
+ "api-ms-win-core-localization-l1-2-0.dll",
+ "api-ms-win-core-processthreads-l1-1-1.dll",
+ "api-ms-win-core-synch-l1-2-0.dll",
+ "api-ms-win-core-timezone-l1-1-0.dll",
+ "api-ms-win-crt-*.dll",
+ "ucrtbase.dll",
+ ]
+ for f in win7_ucrt_redists:
+ FINAL_TARGET_FILES += ["%%%s/%s" % (CONFIG["WIN_UCRT_REDIST_DIR"], f)]