summaryrefslogtreecommitdiffstats
path: root/chrome/test/unit/test_bug415367.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /chrome/test/unit/test_bug415367.js
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'chrome/test/unit/test_bug415367.js')
-rw-r--r--chrome/test/unit/test_bug415367.js47
1 files changed, 47 insertions, 0 deletions
diff --git a/chrome/test/unit/test_bug415367.js b/chrome/test/unit/test_bug415367.js
new file mode 100644
index 0000000000..7af77165a7
--- /dev/null
+++ b/chrome/test/unit/test_bug415367.js
@@ -0,0 +1,47 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ */
+
+function test_uri(obj) {
+ var uri = null;
+ var failed = false;
+ var message = "";
+ try {
+ uri = Services.io.newURI(obj.uri);
+ if (!obj.result) {
+ failed = true;
+ message = obj.uri + " should not be accepted as a valid URI";
+ }
+ } catch (ex) {
+ if (obj.result) {
+ failed = true;
+ message = obj.uri + " should be accepted as a valid URI";
+ }
+ }
+ if (failed) {
+ do_throw(message);
+ }
+ if (obj.result) {
+ Assert.ok(uri != null);
+ Assert.equal(uri.spec, obj.uri);
+ }
+}
+
+function run_test() {
+ var tests = [
+ { uri: "chrome://blah/content/blah.xul", result: true },
+ { uri: "chrome://blah/content/:/blah/blah.xul", result: true },
+ { uri: "chrome://blah/content/%252e./blah/blah.xul", result: true },
+ { uri: "chrome://blah/content/%252e%252e/blah/blah.xul", result: true },
+ { uri: "chrome://blah/content/blah.xul?param=%252e./blah/", result: true },
+ { uri: "chrome://blah/content/blah.xul?param=:/blah/", result: true },
+ {
+ uri: "chrome://blah/content/blah.xul?param=%252e%252e/blah/",
+ result: true,
+ },
+ ];
+ for (var i = 0; i < tests.length; ++i) {
+ test_uri(tests[i]);
+ }
+}