summaryrefslogtreecommitdiffstats
path: root/comm/docs/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /comm/docs/Makefile
parentInitial commit. (diff)
downloadthunderbird-upstream.tar.xz
thunderbird-upstream.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'comm/docs/Makefile')
-rw-r--r--comm/docs/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/comm/docs/Makefile b/comm/docs/Makefile
new file mode 100644
index 0000000000..a9bc6a02c3
--- /dev/null
+++ b/comm/docs/Makefile
@@ -0,0 +1,32 @@
+# Minimal makefile for Sphinx documentation
+#
+
+VENV = _venv
+
+# You can set these variables from the command line, and also
+# from the environment for the first two.
+SPHINXOPTS ?=
+SPHINXBUILD ?= ./$(VENV)/bin/sphinx-build
+SOURCEDIR = .
+BUILDDIR = _build
+
+
+# Put it first so that "make" without argument is like "make help".
+help:
+ @$(SPHINXBUILD) -M help "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+
+venv: Makefile
+ python -m venv --upgrade-deps $(VENV)
+ ./$(VENV)/bin/pip install -r requirements.txt
+
+
+clean:
+ @rm -rf $(VENV) $(BUILDDIR)
+
+
+.PHONY: help Makefile $(SPHINXBUILD)
+
+# Catch-all target: route all unknown targets to Sphinx using the new
+# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).
+%: $(SPHINXBUILD)
+ @$(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)