summaryrefslogtreecommitdiffstats
path: root/gfx/wr/fog
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /gfx/wr/fog
parentInitial commit. (diff)
downloadthunderbird-upstream.tar.xz
thunderbird-upstream.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'gfx/wr/fog')
-rw-r--r--gfx/wr/fog/Cargo.toml9
-rw-r--r--gfx/wr/fog/src/main.rs7
2 files changed, 16 insertions, 0 deletions
diff --git a/gfx/wr/fog/Cargo.toml b/gfx/wr/fog/Cargo.toml
new file mode 100644
index 0000000000..a45cc52277
--- /dev/null
+++ b/gfx/wr/fog/Cargo.toml
@@ -0,0 +1,9 @@
+[package]
+name = "firefox-on-glean"
+version = "0.1.0"
+edition = "2018"
+license = "MPL-2.0"
+
+# This is a dummy crate for non-gecko builds.
+
+[dependencies]
diff --git a/gfx/wr/fog/src/main.rs b/gfx/wr/fog/src/main.rs
new file mode 100644
index 0000000000..a58657b036
--- /dev/null
+++ b/gfx/wr/fog/src/main.rs
@@ -0,0 +1,7 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+fn main() {
+ println!("Hello, world!");
+}