summaryrefslogtreecommitdiffstats
path: root/media/libsoundtouch/moz.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /media/libsoundtouch/moz.yaml
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'media/libsoundtouch/moz.yaml')
-rw-r--r--media/libsoundtouch/moz.yaml96
1 files changed, 96 insertions, 0 deletions
diff --git a/media/libsoundtouch/moz.yaml b/media/libsoundtouch/moz.yaml
new file mode 100644
index 0000000000..f3d0da4516
--- /dev/null
+++ b/media/libsoundtouch/moz.yaml
@@ -0,0 +1,96 @@
+schema: 1
+
+bugzilla:
+ product: "Core"
+ component: "Audio/Video"
+
+# The whole library is not used, only the relevant files are imported in the
+# tree, using the script `update.sh`. Some changes have been made to the files,
+# using the patch `moz-libsoundtouch.patch`.
+# We also use a custom soundtouch_config.h.
+
+origin:
+ name: "SoundTouch"
+ description: "Audio processing library"
+
+ url: "http://www.surina.net/soundtouch"
+ license: "LGPL-2.1"
+
+ release: 17a63e99d58053b0fbde8b69d7cc76a38119ce70 (2021-03-03T18:11:45+02:00).
+ revision: 17a63e99d58053b0fbde8b69d7cc76a38119ce70
+
+vendoring:
+ url: https://codeberg.org/soundtouch/soundtouch
+ source-hosting: codeberg
+ tracking: commit
+
+ exclude:
+ - bin
+ - bootstrap
+ - config
+ - configure.ac
+ - createsrcpack
+ - Makefile.am
+ - make-win.bat
+ - README.html
+ - readme.md
+ - soundtouch.m4
+ - soundtouch.pc.in
+ - ".*"
+ - "source/Android-lib"
+ - "source/*/*/*"
+ - "source/*/*"
+ - "source/*/.*"
+ - "source/*"
+ - "include/*"
+
+ include:
+ - COPYING.TXT
+ - include/SoundTouch.h
+ - include/FIFOSampleBuffer.h
+ - include/FIFOSamplePipe.h
+ - include/STTypes.h
+ - source/SoundTouch/AAFilter.cpp
+ - source/SoundTouch/AAFilter.h
+ - source/SoundTouch/cpu_detect.h
+ - source/SoundTouch/cpu_detect_x86.cpp
+ - source/SoundTouch/FIFOSampleBuffer.cpp
+ - source/SoundTouch/FIRFilter.cpp
+ - source/SoundTouch/FIRFilter.h
+ - source/SoundTouch/InterpolateLinear.cpp
+ - source/SoundTouch/InterpolateLinear.h
+ - source/SoundTouch/InterpolateCubic.cpp
+ - source/SoundTouch/InterpolateCubic.h
+ - source/SoundTouch/InterpolateShannon.cpp
+ - source/SoundTouch/InterpolateShannon.h
+ - source/SoundTouch/mmx_optimized.cpp
+ - source/SoundTouch/RateTransposer.cpp
+ - source/SoundTouch/RateTransposer.h
+ - source/SoundTouch/SoundTouch.cpp
+ - source/SoundTouch/sse_optimized.cpp
+ - source/SoundTouch/TDStretch.cpp
+ - source/SoundTouch/TDStretch.h
+
+ keep:
+ - AUTHORS
+ - clear-lf.sh
+ - src/SoundTouchFactory.*
+ - src/soundtouch_config.h
+ - src/soundtouch_perms.h
+
+ patches:
+ - moz-libsoundtouch.patch
+
+ update-actions:
+ - action: move-file
+ from: '{vendor_dir}/COPYING.TXT'
+ to: '{vendor_dir}/LICENSE'
+ - action: move-dir
+ from: '{vendor_dir}/source/SoundTouch'
+ to: '{vendor_dir}/src'
+ - action: move-dir
+ from: '{vendor_dir}/include'
+ to: '{vendor_dir}/src'
+ - action: run-script
+ script: '{yaml_dir}/clear-lf.sh'
+ cwd: '{yaml_dir}'