summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/packages/browsers/test/src/chromium/chromium-data.spec.ts
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /remote/test/puppeteer/packages/browsers/test/src/chromium/chromium-data.spec.ts
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'remote/test/puppeteer/packages/browsers/test/src/chromium/chromium-data.spec.ts')
-rw-r--r--remote/test/puppeteer/packages/browsers/test/src/chromium/chromium-data.spec.ts108
1 files changed, 108 insertions, 0 deletions
diff --git a/remote/test/puppeteer/packages/browsers/test/src/chromium/chromium-data.spec.ts b/remote/test/puppeteer/packages/browsers/test/src/chromium/chromium-data.spec.ts
new file mode 100644
index 0000000000..5dae0d0d29
--- /dev/null
+++ b/remote/test/puppeteer/packages/browsers/test/src/chromium/chromium-data.spec.ts
@@ -0,0 +1,108 @@
+/**
+ * Copyright 2023 Google Inc. All rights reserved.
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+import assert from 'assert';
+import path from 'path';
+
+import {
+ BrowserPlatform,
+ ChromeReleaseChannel,
+} from '../../../lib/cjs/browser-data/browser-data.js';
+import {
+ resolveDownloadUrl,
+ relativeExecutablePath,
+ resolveSystemExecutablePath,
+} from '../../../lib/cjs/browser-data/chromium.js';
+
+describe('Chromium', () => {
+ it('should resolve download URLs', () => {
+ assert.strictEqual(
+ resolveDownloadUrl(BrowserPlatform.LINUX, '1083080'),
+ 'https://storage.googleapis.com/chromium-browser-snapshots/Linux_x64/1083080/chrome-linux.zip'
+ );
+ assert.strictEqual(
+ resolveDownloadUrl(BrowserPlatform.MAC, '1083080'),
+ 'https://storage.googleapis.com/chromium-browser-snapshots/Mac/1083080/chrome-mac.zip'
+ );
+ assert.strictEqual(
+ resolveDownloadUrl(BrowserPlatform.MAC_ARM, '1083080'),
+ 'https://storage.googleapis.com/chromium-browser-snapshots/Mac_Arm/1083080/chrome-mac.zip'
+ );
+ assert.strictEqual(
+ resolveDownloadUrl(BrowserPlatform.WIN32, '1083080'),
+ 'https://storage.googleapis.com/chromium-browser-snapshots/Win/1083080/chrome-win.zip'
+ );
+ assert.strictEqual(
+ resolveDownloadUrl(BrowserPlatform.WIN64, '1083080'),
+ 'https://storage.googleapis.com/chromium-browser-snapshots/Win_x64/1083080/chrome-win.zip'
+ );
+ });
+
+ it('should resolve executable paths', () => {
+ assert.strictEqual(
+ relativeExecutablePath(BrowserPlatform.LINUX, '12372323'),
+ path.join('chrome-linux', 'chrome')
+ );
+ assert.strictEqual(
+ relativeExecutablePath(BrowserPlatform.MAC, '12372323'),
+ path.join('chrome-mac', 'Chromium.app', 'Contents', 'MacOS', 'Chromium')
+ );
+ assert.strictEqual(
+ relativeExecutablePath(BrowserPlatform.MAC_ARM, '12372323'),
+ path.join('chrome-mac', 'Chromium.app', 'Contents', 'MacOS', 'Chromium')
+ );
+ assert.strictEqual(
+ relativeExecutablePath(BrowserPlatform.WIN32, '12372323'),
+ path.join('chrome-win', 'chrome.exe')
+ );
+ assert.strictEqual(
+ relativeExecutablePath(BrowserPlatform.WIN64, '12372323'),
+ path.join('chrome-win', 'chrome.exe')
+ );
+ });
+
+ it('should resolve system executable path', () => {
+ process.env['PROGRAMFILES'] = 'C:\\ProgramFiles';
+ try {
+ assert.strictEqual(
+ resolveSystemExecutablePath(
+ BrowserPlatform.WIN32,
+ ChromeReleaseChannel.DEV
+ ),
+ 'C:\\ProgramFiles\\Google\\Chrome Dev\\Application\\chrome.exe'
+ );
+ } finally {
+ delete process.env['PROGRAMFILES'];
+ }
+
+ assert.strictEqual(
+ resolveSystemExecutablePath(
+ BrowserPlatform.MAC,
+ ChromeReleaseChannel.BETA
+ ),
+ '/Applications/Google Chrome Beta.app/Contents/MacOS/Google Chrome Beta'
+ );
+ assert.throws(() => {
+ assert.strictEqual(
+ resolveSystemExecutablePath(
+ BrowserPlatform.LINUX,
+ ChromeReleaseChannel.CANARY
+ ),
+ path.join('chrome-linux', 'chrome')
+ );
+ }, new Error(`Unable to detect browser executable path for 'canary' on linux.`));
+ });
+});