summaryrefslogtreecommitdiffstats
path: root/testing/condprofile/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /testing/condprofile/Makefile
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/condprofile/Makefile')
-rw-r--r--testing/condprofile/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/condprofile/Makefile b/testing/condprofile/Makefile
new file mode 100644
index 0000000000..b626f5c7e9
--- /dev/null
+++ b/testing/condprofile/Makefile
@@ -0,0 +1,23 @@
+HERE = $(shell pwd)
+BIN = $(HERE)/bin
+PYTHON = $(BIN)/python
+INSTALL = $(BIN)/pip install --no-deps
+BUILD_DIRS = bin build include lib lib64 man share
+VIRTUALENV = virtualenv
+
+.PHONY: all test build docs
+
+all: build
+
+$(PYTHON):
+ $(VIRTUALENV) $(VTENV_OPTS) .
+
+build: $(PYTHON)
+ $(PYTHON) setup.py develop
+ $(BIN)/pip install tox
+
+test: build
+ $(BIN)/tox
+
+docs: build
+ $(BIN)/tox -e docs