summaryrefslogtreecommitdiffstats
path: root/testing/condprofile/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /testing/condprofile/setup.py
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/condprofile/setup.py')
-rw-r--r--testing/condprofile/setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/condprofile/setup.py b/testing/condprofile/setup.py
new file mode 100644
index 0000000000..ba91c7f828
--- /dev/null
+++ b/testing/condprofile/setup.py
@@ -0,0 +1,31 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import find_packages, setup
+
+entry_points = """
+ [console_scripts]
+ cp-creator = condprof.main:main
+ cp-client = condprof.client:main
+ """
+
+setup(
+ name="conditioned-profile",
+ version="0.2",
+ packages=find_packages(),
+ description="Firefox Heavy Profile creator",
+ include_package_data=True,
+ data_files=[
+ (
+ "condprof",
+ [
+ "condprof/customization/default.json",
+ "condprof/customization/youtube.json",
+ ],
+ )
+ ],
+ zip_safe=False,
+ install_requires=[], # use requirements files
+ entry_points=entry_points,
+)