summaryrefslogtreecommitdiffstats
path: root/testing/mozharness/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /testing/mozharness/setup.py
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/mozharness/setup.py')
-rw-r--r--testing/mozharness/setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/mozharness/setup.py b/testing/mozharness/setup.py
new file mode 100644
index 0000000000..0c4a9e7186
--- /dev/null
+++ b/testing/mozharness/setup.py
@@ -0,0 +1,44 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+import os
+from setuptools import setup, find_packages
+
+try:
+ here = os.path.dirname(os.path.abspath(__file__))
+ description = open(os.path.join(here, "README.txt")).read()
+except IOError:
+ description = ""
+
+import mozharness
+
+version = mozharness.version_string
+
+dependencies = ["virtualenv", "mock", "coverage", "nose", "pylint", "pyflakes"]
+try:
+ import json
+except ImportError:
+ dependencies.append("simplejson")
+
+setup(
+ name="mozharness",
+ version=version,
+ description="Mozharness is a configuration-driven script harness with full logging that allows production infrastructure and individual developers to use the same scripts. ",
+ long_description=description,
+ classifiers=[
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 2 :: Only",
+ ], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+ author="Aki Sasaki",
+ author_email="aki@mozilla.com",
+ url="https://hg.mozilla.org/build/mozharness/",
+ license="MPL",
+ packages=find_packages(exclude=["ez_setup", "examples", "tests"]),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=dependencies,
+ entry_points="""
+ # -*- Entry points: -*-
+ """,
+)