summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/custom-elements/upgrading/Document-importNode.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /testing/web-platform/tests/custom-elements/upgrading/Document-importNode.html
parentInitial commit. (diff)
downloadthunderbird-upstream.tar.xz
thunderbird-upstream.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/custom-elements/upgrading/Document-importNode.html')
-rw-r--r--testing/web-platform/tests/custom-elements/upgrading/Document-importNode.html32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/web-platform/tests/custom-elements/upgrading/Document-importNode.html b/testing/web-platform/tests/custom-elements/upgrading/Document-importNode.html
new file mode 100644
index 0000000000..3da4ccf46a
--- /dev/null
+++ b/testing/web-platform/tests/custom-elements/upgrading/Document-importNode.html
@@ -0,0 +1,32 @@
+<!DOCTYPE html>
+<link rel="help" href="https://dom.spec.whatwg.org/#dom-document-importnode">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script src="../resources/custom-elements-helpers.js"></script>
+<body>
+<script>
+test_with_window((w, doc) => {
+ class MyElement extends HTMLElement {}
+ class MyElement2 extends w.HTMLElement {}
+ customElements.define('my-element', MyElement);
+ w.customElements.define('my-element', MyElement2);
+
+ let original = document.createElement('my-element');
+ assert_true(original instanceof MyElement);
+
+ let imported = doc.importNode(original);
+ assert_true(imported instanceof MyElement2);
+}, 'autonomous: document.importNode() should import custom elements successfully');
+
+test_with_window((w, doc) => {
+ class MyElement3 extends w.HTMLElement {}
+ w.customElements.define('my-element3', MyElement3);
+
+ let original = document.createElement('my-element3');
+ assert_equals(original.constructor, HTMLElement);
+
+ let imported = doc.importNode(original);
+ assert_true(imported instanceof MyElement3);
+}, 'autonomous: document.importNode() should import "undefined" custom elements successfully');
+</script>
+</body>