summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/storage/persist-permission-manual.https.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /testing/web-platform/tests/storage/persist-permission-manual.https.html
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/storage/persist-permission-manual.https.html')
-rw-r--r--testing/web-platform/tests/storage/persist-permission-manual.https.html27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/web-platform/tests/storage/persist-permission-manual.https.html b/testing/web-platform/tests/storage/persist-permission-manual.https.html
new file mode 100644
index 0000000000..aa49900d69
--- /dev/null
+++ b/testing/web-platform/tests/storage/persist-permission-manual.https.html
@@ -0,0 +1,27 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <meta charset="utf-8">
+ <title>StorageManager: permission state is granted</title>
+ <p>Clear all persistent storage permissions before running this test.</p>
+ <p>Test passes if there is a permission prompt and click allow store persistent data</p>
+ <meta name="help" href="https://storage.spec.whatwg.org/#dom-storagemanager-persist">
+ <meta name="author" title="Mozilla" href="https://www.mozilla.org">
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ </head>
+ <body>
+ <script>
+ promise_test(function(t) {
+ return navigator.storage.persist()
+ .then(function(result) {
+ assert_true(result);
+ return navigator.storage.persisted();
+ })
+ .then(function(result) {
+ assert_true(result);
+ })
+ }, 'Expect permission state is granted after calling persist()');
+ </script>
+ </body>
+</html>