summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/tools/mypy.ini
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /testing/web-platform/tests/tools/mypy.ini
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/tools/mypy.ini')
-rw-r--r--testing/web-platform/tests/tools/mypy.ini124
1 files changed, 124 insertions, 0 deletions
diff --git a/testing/web-platform/tests/tools/mypy.ini b/testing/web-platform/tests/tools/mypy.ini
new file mode 100644
index 0000000000..5dc55c5b74
--- /dev/null
+++ b/testing/web-platform/tests/tools/mypy.ini
@@ -0,0 +1,124 @@
+[mypy]
+# Here some paths are excluded from even being parsed, working around cases of
+# invalid syntax we can't fix (yet) or where the code isn't in a package and
+# there's no good place to add __init__.py files. The following are excluded:
+# - tools/third_party/ (vendored dependencies)
+# - All setup.py files (avoiding duplicate module named "setup")
+# - tools/wptserve/docs/conf.py (generated code)
+# - tools/wptserve/tests/ (deliberately invalid syntax)
+exclude = (^tools/third_party/|/setup\.py$|^tools/wptserve/docs/conf.py|^tools/wptserve/tests/)
+mypy_path = tools/wptrunner:tools/wptserve:tools/webdriver:tools/webtransport
+#check_untyped_defs = True
+disallow_any_generics = True
+disallow_incomplete_defs = True
+disallow_subclassing_any = True
+disallow_untyped_calls = True
+disallow_untyped_decorators = True
+disallow_untyped_defs = True
+no_implicit_optional = True
+strict_equality = True
+warn_redundant_casts = True
+warn_return_any = True
+warn_unused_configs = True
+warn_unused_ignores = True
+warn_unreachable = True
+
+show_error_codes = True
+
+# Ignore missing or untyped libraries.
+
+[mypy-Cocoa.*]
+ignore_missing_imports = True
+
+[mypy-ColorSync.*]
+ignore_missing_imports = True
+
+[mypy-Quartz.*]
+ignore_missing_imports = True
+
+[mypy-github.*]
+ignore_missing_imports = True
+
+[mypy-h2.*]
+ignore_missing_imports = True
+
+[mypy-hpack.*]
+ignore_missing_imports = True
+
+[mypy-html5lib.*]
+ignore_missing_imports = True
+
+[mypy-hyperframe.*]
+ignore_missing_imports = True
+
+[mypy-hypothesis.*]
+ignore_missing_imports = True
+
+[mypy-marionette_driver.*]
+ignore_missing_imports = True
+
+[mypy-mod_pywebsocket.*]
+ignore_missing_imports = True
+
+[mypy-mozcrash.*]
+ignore_missing_imports = True
+
+[mypy-mozdebug.*]
+ignore_missing_imports = True
+
+[mypy-mozdevice.*]
+ignore_missing_imports = True
+
+[mypy-mozinfo.*]
+ignore_missing_imports = True
+
+[mypy-mozinstall.*]
+ignore_missing_imports = True
+
+[mypy-mozleak.*]
+ignore_missing_imports = True
+
+[mypy-mozlog.*]
+ignore_missing_imports = True
+
+[mypy-moznetwork.*]
+ignore_missing_imports = True
+
+[mypy-mozprocess.*]
+ignore_missing_imports = True
+
+[mypy-mozprofile.*]
+ignore_missing_imports = True
+
+[mypy-mozrunner.*]
+ignore_missing_imports = True
+
+[mypy-mozversion.*]
+ignore_missing_imports = True
+
+[mypy-PIL.*]
+ignore_missing_imports = True
+
+[mypy-packaging.*]
+ignore_missing_imports = True
+
+[mypy-psutil.*]
+ignore_missing_imports = True
+
+[mypy-pytest.*]
+ignore_missing_imports = True
+
+[mypy-selenium.*]
+ignore_missing_imports = True
+
+[mypy-taskcluster.*]
+ignore_missing_imports = True
+
+[mypy-ua_parser.*]
+ignore_missing_imports = True
+
+[mypy-websockets.*]
+ignore_missing_imports = True
+
+[mypy-zstandard.*]
+ignore_missing_imports = True