summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/workers/shared-worker-name-via-options.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /testing/web-platform/tests/workers/shared-worker-name-via-options.html
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/workers/shared-worker-name-via-options.html')
-rw-r--r--testing/web-platform/tests/workers/shared-worker-name-via-options.html38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/web-platform/tests/workers/shared-worker-name-via-options.html b/testing/web-platform/tests/workers/shared-worker-name-via-options.html
new file mode 100644
index 0000000000..1914d66db7
--- /dev/null
+++ b/testing/web-platform/tests/workers/shared-worker-name-via-options.html
@@ -0,0 +1,38 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>Test the name property of shared workers mixing constructor options and constructor strings</title>
+<link rel="help" href="https://html.spec.whatwg.org/multipage/#concept-workerglobalscope-name">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/#dom-sharedworker">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/#dom-sharedworkerglobalscope-name">
+<link rel="author" title="Domenic Denicola" href="mailto:d@domenic.me">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+
+<script>
+"use strict";
+setup({ single_test: true });
+
+const name = "my name";
+
+const worker1 = new SharedWorker("support/shared-name.js", { name });
+worker1.port.onmessage = receiveMessage;
+
+const worker2 = new SharedWorker("support/shared-name.js", { name });
+worker2.port.onmessage = receiveMessage;
+
+const worker3 = new SharedWorker("support/shared-name.js", name);
+worker3.port.onmessage = receiveMessage;
+
+let nextCounterExpected = 1;
+function receiveMessage(e) {
+ const { counter, name: receivedName } = e.data;
+
+ assert_equals(receivedName, name);
+ assert_equals(counter, nextCounterExpected);
+
+ ++nextCounterExpected;
+ if (nextCounterExpected === 4) {
+ done();
+ }
+}
+</script>