summaryrefslogtreecommitdiffstats
path: root/testing/webdriver/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /testing/webdriver/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-upstream.tar.xz
thunderbird-upstream.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/webdriver/Cargo.toml')
-rw-r--r--testing/webdriver/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/webdriver/Cargo.toml b/testing/webdriver/Cargo.toml
new file mode 100644
index 0000000000..fe2eac51a5
--- /dev/null
+++ b/testing/webdriver/Cargo.toml
@@ -0,0 +1,38 @@
+[package]
+edition = "2018"
+name = "webdriver"
+version = "0.48.0"
+authors = ["Mozilla"]
+include = ["/src"]
+description = "Library implementing the wire protocol for the W3C WebDriver specification."
+documentation = "https://docs.rs/webdriver"
+readme = "README.md"
+keywords = [
+ "automation",
+ "browser",
+ "protocol",
+ "w3c",
+ "webdriver",
+]
+license = "MPL-2.0"
+repository = "https://hg.mozilla.org/mozilla-central/file/tip/testing/webdriver"
+
+[features]
+default = ["server"]
+server = ["tokio", "tokio-stream", "warp"]
+
+[dependencies]
+base64 = "0.13"
+bytes = "1.0"
+cookie = { version = "0.16", default-features = false }
+http = "0.2"
+log = "0.4"
+serde = "1.0"
+serde_json = "1.0"
+serde_derive = "1.0"
+time = "0.3"
+tokio = { version = "1.0", features = ["rt", "net"], optional = true}
+tokio-stream = { version = "0.1", features = ["net"], optional = true}
+unicode-segmentation = "1.2"
+url = "2.0"
+warp = { version = "0.3", default-features = false, optional = true }