summaryrefslogtreecommitdiffstats
path: root/third_party/rust/audio-mixer/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/audio-mixer/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/audio-mixer/Cargo.toml')
-rw-r--r--third_party/rust/audio-mixer/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/third_party/rust/audio-mixer/Cargo.toml b/third_party/rust/audio-mixer/Cargo.toml
new file mode 100644
index 0000000000..085d7c4152
--- /dev/null
+++ b/third_party/rust/audio-mixer/Cargo.toml
@@ -0,0 +1,35 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "audio-mixer"
+version = "0.1.2"
+authors = ["Chun-Min Chang <chun.m.chang@gmail.com>"]
+description = "Mixing audio by the input and output channel layout"
+keywords = ["audio", "mixer", "mixing"]
+categories = ["multimedia::audio"]
+license = "MPL-2.0"
+repository = "https://github.com/ChunMinChang/audio-mixer"
+
+[[bench]]
+name = "benchmark"
+harness = false
+[dependencies.bitflags]
+version = "1.2"
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.float-cmp]
+version = "0.6"
+[badges.travis-ci]
+repository = "ChunMinChang/audio-mixer"