summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crc32fast/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/crc32fast/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/crc32fast/Cargo.toml')
-rw-r--r--third_party/rust/crc32fast/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/third_party/rust/crc32fast/Cargo.toml b/third_party/rust/crc32fast/Cargo.toml
new file mode 100644
index 0000000000..79c0b04b39
--- /dev/null
+++ b/third_party/rust/crc32fast/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "crc32fast"
+version = "1.3.2"
+authors = ["Sam Rijs <srijs@airpost.net>", "Alex Crichton <alex@alexcrichton.com>"]
+description = "Fast, SIMD-accelerated CRC32 (IEEE) checksum computation"
+readme = "README.md"
+keywords = ["checksum", "crc", "crc32", "simd", "fast"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/srijs/rust-crc32fast"
+
+[[bench]]
+name = "bench"
+harness = false
+[dependencies.cfg-if]
+version = "1.0"
+[dev-dependencies.bencher]
+version = "0.1"
+
+[dev-dependencies.quickcheck]
+version = "1.0"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[features]
+default = ["std"]
+nightly = []
+std = []