summaryrefslogtreecommitdiffstats
path: root/third_party/rust/enum-primitive-derive/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/enum-primitive-derive/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-upstream.tar.xz
thunderbird-upstream.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/enum-primitive-derive/Cargo.toml')
-rw-r--r--third_party/rust/enum-primitive-derive/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/third_party/rust/enum-primitive-derive/Cargo.toml b/third_party/rust/enum-primitive-derive/Cargo.toml
new file mode 100644
index 0000000000..96a901e6cc
--- /dev/null
+++ b/third_party/rust/enum-primitive-derive/Cargo.toml
@@ -0,0 +1,37 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "enum-primitive-derive"
+version = "0.2.2"
+authors = ["Doug Goldstein <cardoe@cardoe.com>"]
+description = "enum_primitive implementation using procedural macros to have a custom derive"
+homepage = "https://gitlab.com/cardoe/enum-primitive-derive"
+readme = "README.md"
+keywords = ["derive", "enum", "fromprimitive", "primitive", "ffi"]
+categories = ["rust-patterns"]
+license = "MIT"
+repository = "https://gitlab.com/cardoe/enum-primitive-derive.git"
+
+[lib]
+proc-macro = true
+[dependencies.num-traits]
+version = "0.2"
+default-features = false
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.syn]
+version = "1"
+[badges.gitlab]
+repository = "cardoe/enum-primitive-derive"