summaryrefslogtreecommitdiffstats
path: root/third_party/rust/objc/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/objc/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-upstream.tar.xz
thunderbird-upstream.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/objc/Cargo.toml')
-rw-r--r--third_party/rust/objc/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/objc/Cargo.toml b/third_party/rust/objc/Cargo.toml
new file mode 100644
index 0000000000..08272304b6
--- /dev/null
+++ b/third_party/rust/objc/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "objc"
+version = "0.2.7"
+authors = ["Steven Sheldon"]
+exclude = [".gitignore", ".travis.yml", "doc.sh", "travis_install.sh", "travis_test.sh", "tests-ios/**"]
+description = "Objective-C Runtime bindings and wrapper for Rust."
+documentation = "http://ssheldon.github.io/rust-objc/objc/"
+readme = "README.md"
+keywords = ["objective-c", "osx", "ios", "cocoa", "uikit"]
+license = "MIT"
+repository = "http://github.com/SSheldon/rust-objc"
+[dependencies.malloc_buf]
+version = "0.0"
+
+[dependencies.objc_exception]
+version = "0.1"
+optional = true
+
+[features]
+exception = ["objc_exception"]
+verify_message = []