summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wasi/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /third_party/rust/wasi/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-upstream.tar.xz
thunderbird-upstream.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/wasi/Cargo.toml')
-rw-r--r--third_party/rust/wasi/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/third_party/rust/wasi/Cargo.toml b/third_party/rust/wasi/Cargo.toml
new file mode 100644
index 0000000000..c41e35e9ee
--- /dev/null
+++ b/third_party/rust/wasi/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "wasi"
+version = "0.11.0+wasi-snapshot-preview1"
+authors = ["The Cranelift Project Developers"]
+description = "Experimental WASI API bindings for Rust"
+documentation = "https://docs.rs/wasi"
+readme = "README.md"
+keywords = ["webassembly", "wasm"]
+categories = ["no-std", "wasm"]
+license = "Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT"
+repository = "https://github.com/bytecodealliance/wasi"
+[dependencies.compiler_builtins]
+version = "0.1"
+optional = true
+
+[dependencies.core]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.rustc-std-workspace-alloc]
+version = "1.0"
+optional = true
+
+[features]
+default = ["std"]
+rustc-dep-of-std = ["compiler_builtins", "core", "rustc-std-workspace-alloc"]
+std = []
+[badges.maintenance]
+status = "experimental"